Page 1 of 1

source release tarballs ship with very outdated autoconf

Posted: Fri Aug 15, 2014 5:33 pm
by linrox
the latest release ships with a "jim" that has very outdated autoconf files.
it doesn't recognize my linux-musl toolchain, even though the triple is supported by upstream autoconf since 3 years.
so in order to get it to build i basically had to replace all the autoconf-generated files with recent copies.
next time you draft a release please run autoreconf -i in the jim source dir from an up-to-date linux system before distributing the tarball to fix this issue.
thanks!

Re: source release tarballs ship with very outdated autoconf

Posted: Sat Aug 16, 2014 8:16 am
by Josh
No problem, will do.

Most likely I'll include an updated version of libjim anyway in the next release. The reason:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=751271