Author Message

<  Everything Coding  ~  don't return a value from stack

PostPosted: Thu Jul 21, 2016 6:55 pm Reply with quote
Posts: 23 Joined: Wed Jun 22, 2016 2:17 pm
Please see the attached patch.

Thank you
Lubo
Attachments:
File comment: Suggested fix
0001-usb_modeswitch-don-t-return-a-value-from-stack.patch [1.05 KiB]
Downloaded 174 times

Offline
PostPosted: Wed Sep 07, 2016 8:13 pm Reply with quote
Posts: 23 Joined: Wed Jun 22, 2016 2:17 pm
Ping? This is probably quite serious; at least when built in Fedora the behavior of usb_modeswitch without the patch was totally unpredictable (did the job in ~50% of cases).
Could be the compiler flags we use, but perhaps that happens for other distros too?


Offline
PostPosted: Thu Sep 08, 2016 8:13 am Reply with quote
Site Admin Posts: 6438 Joined: Sat Nov 03, 2007 12:30 am
There were no other reports about such a problem on other distros, AFAIK. Is there an official Fedora bug report?

I will certainly include the patch with the next program package update.


Offline
PostPosted: Thu Sep 08, 2016 12:14 pm Reply with quote
Posts: 23 Joined: Wed Jun 22, 2016 2:17 pm
Josh wrote:
There were no other reports about such a problem on other distros, AFAIK. Is there an official Fedora bug report?


Not really. I've stumbled upon this myself when checking things work well with my modem collection after updating the package. The users don't tend to include too much details in the bug reports -- there's a handful of "my modem won't work" bug reports filed against ModemManager that lack good explanation. I merely suspected this could be related.


Offline

Display posts from previous:  Sort by:

All times are UTC+02:00
Page 1 of 1
4 posts
Users browsing this forum: No registered users and 1 guest
Search for:
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum
cron