USB_ModeSwitch
http://www.draisberghof.de/usb_modeswitch/bb/

don't return a value from stack
http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?f=2&t=2557
Page 1 of 1

Author:  lkundrak [ Thu Jul 21, 2016 6:55 pm ]
Post subject:  don't return a value from stack

Please see the attached patch.

Thank you
Lubo

Attachments:
File comment: Suggested fix
0001-usb_modeswitch-don-t-return-a-value-from-stack.patch [1.05 KiB]
Downloaded 190 times


Author:  lkundrak [ Wed Sep 07, 2016 8:13 pm ]
Post subject:  Re: don't return a value from stack

Ping? This is probably quite serious; at least when built in Fedora the behavior of usb_modeswitch without the patch was totally unpredictable (did the job in ~50% of cases).
Could be the compiler flags we use, but perhaps that happens for other distros too?

Author:  Josh [ Thu Sep 08, 2016 8:13 am ]
Post subject:  Re: don't return a value from stack

There were no other reports about such a problem on other distros, AFAIK. Is there an official Fedora bug report?

I will certainly include the patch with the next program package update.

Author:  lkundrak [ Thu Sep 08, 2016 12:14 pm ]
Post subject:  Re: don't return a value from stack

Josh wrote:
There were no other reports about such a problem on other distros, AFAIK. Is there an official Fedora bug report?


Not really. I've stumbled upon this myself when checking things work well with my modem collection after updating the package. The users don't tend to include too much details in the bug reports -- there's a handful of "my modem won't work" bug reports filed against ModemManager that lack good explanation. I merely suspected this could be related.

Page 1 of 1 All times are UTC+02:00
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/