Author Message

<  Everything Coding  ~  Sakis3g Rebuilt

PostPosted: Wed Apr 18, 2012 9:29 am Reply with quote
Posts: 9 Joined: Wed Apr 18, 2012 8:54 am Website: http://www.trixarian.netLocation: South Africa
I recently rebuilt the sakis3g using the guide on the wiki and the all in one source package.

A few things I noted in my attempt is that while the latest usb_modeswitch builds without problems with sakis3g, the latest usb_modeswitch-data does not seem to work correctly (and not just the error caused by the missing quotation mark (") in 21f5:1000). Sakis3g can switch the devices correctly, but then seems unable to find it. I remedied this by downloading the previous copy of usb_modeswitch-data (20110123) and testing if it would work. It worked successfully, so I did a diff on the two databases, noticed the 15 file difference (04bb:bccd, 1004:614e, 12d1:1f01, a8d:2000, 05c6:1000:uMa=DGT, 1004:61dd, 19d2:0146, 201e:1023, 0af0:7706, 1004:61e7, 19d2:0169, 21f5:1000, 0af0:d001, 1004:61eb, 19d2:1520) between the two, copied those 15 files to the old database and tried to compile and run sakis3g again. It worked and I'm currently posting from it.

This is kind of why I'm here. I need people to test this new build of sakis3g and see if it works for them. I want to see if my building method helped sakis3g's device support or destroyed it. I also note the script is two times bigger than the old one.

You can get the latest copy of the rebuilt sakis3g here (remember to extract it) and the full sources of everything I changed here

I hope to get some feedback on this (mostly because sakis3g's forum is non-existant at the moment)


Last edited by Trixar_za on Sun Jul 14, 2013 6:02 am, edited 2 times in total.

Offline
PostPosted: Fri Aug 10, 2012 5:23 pm Reply with quote
Posts: 9 Joined: Wed Apr 18, 2012 8:54 am Website: http://www.trixarian.netLocation: South Africa
This has been updated to the latest database using the old working database and copying it over the new one. The new database still doesn't work with sakis3g on it's own. 21f5:1000 also STILL has the missing " in it.

Everything at the above links have been replaced with the latest versions of the build.


Offline
PostPosted: Mon Oct 29, 2012 3:22 am Reply with quote
Posts: 9 Joined: Wed Apr 18, 2012 8:54 am Website: http://www.trixarian.netLocation: South Africa
Right, seems I made an error in sakis3g's code trying to strip out the bashism. They're all back in place and now menu selection from the interactive terminal works again! All links have been updated.


Offline
PostPosted: Thu Nov 01, 2012 5:12 pm Reply with quote
Posts: 9 Joined: Wed Apr 18, 2012 8:54 am Website: http://www.trixarian.netLocation: South Africa
Rebuilt sakis3g with latest usb_modeswitch and database. 21f5:1000 STILL has the missing " in it (Good to know you guys bother to read this post ::Sarcasm::). Sakis3g didn't work with the latest database, so just copied the previous 'working' database over the new one - possibly not the best way to do it, but it works... Everything has been updated to reflect the new changes.


Offline
PostPosted: Sat Mar 23, 2013 8:34 pm Reply with quote
Posts: 9 Joined: Wed Apr 18, 2012 8:54 am Website: http://www.trixarian.netLocation: South Africa
Yet another update. While the latest database compiles properly, it seems sakis3g is unable to use it. Guess a rewrite of Sakis3G is needed to use usb-modeswitch properly. Copying over the last working copy of the database seems to still fix this - for older devices anyway.


Offline
PostPosted: Wed Jul 31, 2013 8:55 am Reply with quote
Posts: 9 Joined: Wed Apr 18, 2012 8:54 am Website: http://www.trixarian.netLocation: South Africa
Considering I got a few downloads and back links from here, I guess it's time for a proper update post for you guys.

Changes since I was last here:
I found out the main problem with switching related to Sakis3g. It seems to rely on DefaultProduct, DefaultVendor and CheckSuccess even though it's NOT explicitly used in the code. This is why any definition files written in the new style doesn't work with Sakis3g at all. I've tried including either values set by themselves, but it refused work unless both Default* and CheckSuccess was included. This meant I had to alter 91 files by hand to fit the old format. The result? New definition files now run near flawlessly when copied over the older (and working) database - the only flaw being that I had to guess the CheckSuccess value for some of the files, but that gets fixed as it's reported.

A copy of the last working database (before the switch over to the new format/style) can be downloaded here and the modified definition files of the newest database can be grabbed from here. Just copy the one over the other and you'll have a working and up-to-date version of the usb_modeswitch database that's compatible with Sakis3g.

As always, the latest i386 build can be grabbed here with the source code (with the latest usb_modeswitch and database) can be found here.

You can also find the guide to how to compile the source code yourself here thanks to Archive.org

EDIT: I added a github repository for the source code here


Last edited by Trixar_za on Sun Aug 04, 2013 2:03 pm, edited 1 time in total.

Offline
PostPosted: Wed Jul 31, 2013 10:12 pm Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
Hmm, but you could have used the default ID values from the file names ...

It was in fact a redundancy to have the default USB ID both in the config file name and in the config file content. If you know the right config file name to give to usb_modeswitch on the command line, you can also give the default vendor and product ID on the command line.


Offline
PostPosted: Fri Aug 02, 2013 2:05 am Reply with quote
Posts: 9 Joined: Wed Apr 18, 2012 8:54 am Website: http://www.trixarian.netLocation: South Africa
That's what so baffling about it because it does use the file's name during database generation and not DefaultVendor or DefaultProduct. I tried commenting out the code that uses it (scripts/device-database-gen and src/sakis3g) and it made no difference. It's clearly a bug in Sakis3g, but one I don't know how to fix it beyond recreating the files in the old syntax format.


Offline
PostPosted: Sun Mar 30, 2014 12:12 pm Reply with quote
Posts: 9 Joined: Wed Apr 18, 2012 8:54 am Website: http://www.trixarian.netLocation: South Africa
Yet another update to Github (fixing compile errors and moving to libusb-1.x support) and to http://trixarian.net/sakis3g.gz.

I've identified the problem that breaks usb_modeswitch with sakis3g when used internally. It's the database generation script that's broken and it doesn't support the current syntax. If I can fix this, we should be able to keep usb_modeswitch current without requiring any changes to usb_modeswitch's sources.


Offline
PostPosted: Mon Apr 14, 2014 7:21 pm Reply with quote
Posts: 9 Joined: Wed Apr 18, 2012 8:54 am Website: http://www.trixarian.netLocation: South Africa
So I identified the problem with Sakis3G and why it can't use databases that doesn't use the old format. It's down to the fact that Sakis3G uses the usb_modeswitch binary instead of the dispatcher script. When the configuration file is used in this way, the binary will complain about the lack of a DefaultVendor and DefaultProduct ID numbers.

So basically, it's Josh's fault :P

However, when you supply the defaults via the -v and -p flags, it does switch the device... But it then becomes unable to locate the interface to connect it. I'm guessing this is why Sakis3G needs the CheckSuccess variable set too.

Atleast I'm getting closer to making Sakis3G fully compatible with the current database. I'll keep you all posted.


Offline

Display posts from previous:  Sort by:

All times are UTC+02:00
Page 1 of 1
10 posts
Users browsing this forum: No registered users and 1 guest
Search for:
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum