Author Message

<  Device Information  ~  Huawei E3372h-607 can't mode switch (Centos 6.10)

PostPosted: Sun Sep 16, 2018 2:51 pm Reply with quote
Posts: 1 Joined: Sun Sep 16, 2018 1:45 pm
I'm totally unable to get the usb_modeswitch command (both distro and latest) to switch my E3372h-607 (Optus) out of storage mode. I'm using CentOS 6.

The command finds the device but none of a variety of options tried results in a change despite appearing to work:

Code:
# usb_modeswitch -V 12d1 -v 12d1 -p 1f01 -P14dc -J -W
...
Found devices in default mode (1)
Access device 010 on bus 002
Get the current device configuration ...
Current configuration number is 1
Use interface number 0
 with class 8
Use endpoints 0x01 (out) and 0x81 (in)

USB description data (for identification)
-------------------------
Manufacturer: HUAWEI_MOBILE
     Product: HUAWEI_MOBILE
  Serial No.: 0123456789ABCDEF
-------------------------
Using standard Huawei switching message
Looking for active drivers ...
Set up interface 0
Use endpoint 0x01 for message sending ...
Trying to send message 1 to endpoint 0x01 ...
 OK, message successfully sent
Read the response to message 1 (CSW) ...
 Response successfully read (13 bytes), status 0
Reset response endpoint 0x81
Reset message endpoint 0x01
-> Run lsusb to note any changes. Bye!


Edit:

I extracted the linux drivers from the virtual CD and installed enough stuff to get their "mbbservice" binary to run. That immediately switched the device to 12d1:14dc and the kernel recognised it as a cdc_ether device.


Offline

Display posts from previous:  Sort by:

All times are UTC+02:00
Page 1 of 1
1 post
Users browsing this forum: No registered users and 3 guests
Search for:
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum