Author Message

<  Device Information  ~  Yet again Alcatel OneTouch X602D

PostPosted: Mon Jun 26, 2017 7:55 pm Reply with quote
Posts: 2 Joined: Mon Jun 26, 2017 7:51 pm
Hello, I need help with this new Alcatel Onetouch x602d which I can see is supported by usb_modeswitch.
First of all, I replaced the binary shipped with my OS with latest usb_modeswitch 2.5.0, since the old one caused libc crashes. I also installed the latest data files.
My OS is ubuntu xenial 16.04 and when I plug my x602d into, it works a bit (red flashing), then blinks blue: this means it's registering to a 3G network. Nevertheless, it never stops blinking and Network Manager does not allow me to activate my existing broadband connection, used with my old (now broken) usb stick.
The output of dmesg is:
Code:
[  163.856682] usb 1-2: new high-speed USB device number 4 using xhci_hcd
[  163.998839] usb 1-2: New USB device found, idVendor=05e3, idProduct=0608
[  163.998846] usb 1-2: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[  163.998851] usb 1-2: Product: USB2.0 Hub
[  164.001207] hub 1-2:1.0: USB hub found
[  164.001484] hub 1-2:1.0: 4 ports detected
[  171.000439] usb 1-2.4: new high-speed USB device number 5 using xhci_hcd
[  171.101581] usb 1-2.4: New USB device found, idVendor=1bbb, idProduct=022c
[  171.101588] usb 1-2.4: New USB device strings: Mfr=2, Product=1, SerialNumber=0
[  171.101593] usb 1-2.4: Product: HSPA+ USB Modem
[  171.101597] usb 1-2.4: Manufacturer: Spreadtrum
[  171.743228] usb-storage 1-2.4:1.0: USB Mass Storage device detected
[  171.743408] scsi host2: usb-storage 1-2.4:1.0
[  171.743574] usbcore: registered new interface driver usb-storage
[  171.754054] usbcore: registered new interface driver uas
[  171.895937] usb 1-2.4: usbfs: interface 0 claimed by usb-storage while 'usb_modeswitch' sets config #2

so, I decided to blacklist the modules uas and usb-storage (doing so, what will I miss?).

Rebooted, then plugged my x602d in, then it blinks blue. Nothing changed.
The output from dmesg is different now:
Code:
[  258.548405] usb 1-2: new high-speed USB device number 4 using xhci_hcd
[  258.690329] usb 1-2: New USB device found, idVendor=05e3, idProduct=0608
[  258.690336] usb 1-2: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[  258.690341] usb 1-2: Product: USB2.0 Hub
[  258.692583] hub 1-2:1.0: USB hub found
[  258.692861] hub 1-2:1.0: 4 ports detected
[  265.692192] usb 1-2.4: new high-speed USB device number 5 using xhci_hcd
[  265.793392] usb 1-2.4: New USB device found, idVendor=1bbb, idProduct=022c
[  265.793399] usb 1-2.4: New USB device strings: Mfr=2, Product=1, SerialNumber=0
[  265.793404] usb 1-2.4: Product: HSPA+ USB Modem
[  265.793408] usb 1-2.4: Manufacturer: Spreadtrum

I also enabled the logger, here is the log:

Code:
USB_ModeSwitch log from Mon Jun  26 19:27:45 CEST 2017

Use global config file: /etc/usb_modeswitch.conf
Raw parameters: {--switch-mode} {1-2.4}
Use top device dir /sys/bus/usb/devices/1-2.4
Check class of first interface ...
 Interface 0 class is 08.

----------------
USB values from sysfs:
  manufacturer   Spreadtrum
  product   HSPA+ USB Modem
  serial
----------------
Found packed config collection /usr/share/usb_modeswitch/configPack.tar.gz
ConfigList: /usr/share/usb_modeswitch/1bbb:022c pack/1bbb:022c pack/
SCSI attributes not needed, move on
Check config: /usr/share/usb_modeswitch/1bbb:022c
! matched. Read config data
Device may have an MBIM configuration, check driver ...
 driver for MBIM devices is available
Find MBIM configuration number ...
 No MBIM configuration found, switch to legacy modem mode
Command line:
usb_modeswitch -W -D  -b 1 -g 5 -v 1bbb -p 022c -f $flags(config)

Verbose debug output of usb_modeswitch and libusb follows
(Note that some USB errors are to be expected in the process)
--------------------------------

Read long config from command line

 * usb_modeswitch: handle USB devices with multiple modes
 * Version 2.5.0 (C) Josua Dietze 2017
 * Based on libusb1/libusbx

 ! PLEASE REPORT NEW CONFIGURATIONS !

DefaultVendor=  0x1bbb
DefaultProduct= 0x022c
Configuration=0x02
System integration mode enabled

Use given bus/device number: 001/005 ...
Look for default devices ...
 bus/device number matched
  found USB ID 1bbb:022c
   vendor ID matched
   product ID matched
Get the current device configuration ...
   device configuration 1 not matching target
   count device
 Found devices in default mode (1)
Get the current device configuration ...
Current configuration number is 1
Use interface number 0
 with class 8

USB description data (for identification)
-------------------------
Manufacturer: Spreadtrum
     Product: HSPA+ USB Modem
  Serial No.: not provided
-------------------------
Change configuration to 2 ...
 OK, configuration set
Get the current device configuration ...
The configuration was set successfully
ok:busdev
--------------------------------
(end of usb_modeswitch output)

Check success of mode switch for max. 20 seconds ...
 Read attributes ...
 All attributes matched
Mode switching was successful, found 1bbb:022c (Spreadtrum: HSPA+ USB Modem)
Logger is /usr/bin/logger
Check for AVOID_RESET_QUIRK kernel attribute
 AVOID_RESET_QUIRK activated

All done, exit


Well, did the x602d switch successfully ? (it seems so)
Now, what am I missing ? My broadband connection is still not available.
Why does this stick not register to the network ? Please note that when I use that same SIM into a normal smartphone, it registers to its network in no more than ten seconds, and then I'm free to surf the web as I want to.
Can anybody help?


Offline
PostPosted: Tue Jun 27, 2017 2:10 pm Reply with quote
Posts: 1175 Joined: Wed Jul 11, 2012 3:14 pm Location: Koh Samui, TH
Manually load serial driver, see
viewtopic.php?f=4&t=2677

Everything there applies to your model also.


Offline
PostPosted: Tue Jun 27, 2017 9:23 pm Reply with quote
Posts: 2 Joined: Mon Jun 26, 2017 7:51 pm
Serial driver is what it needed!!!
Thank you!


Offline

Display posts from previous:  Sort by:

All times are UTC+02:00
Page 1 of 1
3 posts
Users browsing this forum: Google [Bot] and 2 guests
Search for:
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum