USB_ModeSwitch
http://www.draisberghof.de/usb_modeswitch/bb/

Huawei E5577Cs-321 - no ttyUSB
http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?f=3&t=2769
Page 1 of 1

Author:  johannu [ Sun Jan 28, 2018 12:24 pm ]
Post subject:  Huawei E5577Cs-321 - no ttyUSB

Hallo,

I have a Huawei E5577Cs-321.

usb_modeswitch -e gives me:
* usb_modeswitch: handle USB devices with multiple modes
* Version 2.5.2 (C) Josua Dietze 2017
* Based on libusb1/libusbx

! PLEASE REPORT NEW CONFIGURATIONS !

lsusb gives me:
Bus 001 Device 004: ID 12d1:14dc Huawei Technologies Co., Ltd.

usb-devices gives me:
T: Bus=01 Lev=01 Prnt=01 Port=01 Cnt=02 Dev#= 4 Spd=480 MxCh= 0
D: Ver= 2.10 Cls=02(commc) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=12d1 ProdID=14dc Rev=01.02
S: Manufacturer=HUAWEI_MOBILE
S: Product=HUAWEI_MOBILE
C: #Ifs= 3 Cfg#= 1 Atr=80 MxPwr=2mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=02(commc) Sub=06 Prot=00 Driver=cdc_ether
I: If#= 1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=06 Prot=00 Driver=cdc_ether
I: If#= 2 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage

dmes g| greb usb gives me:
[ 688.395620] usb 1-2: new high-speed USB device number 3 using xhci_hcd
[ 688.537263] usb 1-2: New USB device found, idVendor=12d1, idProduct=1f01
[ 688.537271] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 688.537275] usb 1-2: Product: HUAWEI_MOBILE
[ 688.537278] usb 1-2: Manufacturer: HUAWEI_MOBILE
[ 688.537280] usb 1-2: SerialNumber: xxxxxxxxxxxxxxxx
[ 688.538612] usb-storage 1-2:1.0: USB Mass Storage device detected
[ 688.539001] scsi host7: usb-storage 1-2:1.0
[ 689.129037] usb 1-2: USB disconnect, device number 3
[ 689.551568] usb 1-2: new high-speed USB device number 4 using xhci_hcd
[ 689.693173] usb 1-2: New USB device found, idVendor=12d1, idProduct=14dc
[ 689.693182] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 689.693185] usb 1-2: Product: HUAWEI_MOBILE
[ 689.693188] usb 1-2: Manufacturer: HUAWEI_MOBILE
[ 689.696320] usb-storage 1-2:1.2: USB Mass Storage device detected
[ 689.696499] scsi host7: usb-storage 1-2:1.2
[ 689.732765] cdc_ether 1-2:1.0 eth1: register 'cdc_ether' at usb-0000:00:14.0-2, CDC Ethernet Device, 0c:5b:8f:27:9a:64
[ 689.732813] usbcore: registered new interface driver cdc_ether

I think usb_modeswitch switches correctly, but I have no ttyUSB. How can I get it?

Thank you for your help!

Author:  LOM [ Sun Jan 28, 2018 3:22 pm ]
Post subject:  Re: Huawei E5577Cs-321 - no ttyUSB

johannu wrote:
I have no ttyUSB. How can I get it?

Thank you for your help!


You can't.
This is not a dialup modem, it is a LTE CAT4 router and management of it is handled through its built-in web server over the usb ethernet interface or over wifi.

Author:  lila [ Fri Mar 09, 2018 2:30 pm ]
Post subject:  Re: Huawei E5577Cs-321 - no ttyUSB

Hello and thank you for all the great work.
I just subscribed because I have a Huawei E5573Cs-322 that should be related to the 5577Cs-321.
I can install it on windows and mac, and it seems to be switching on my openwrt and LEDE virtual machines, but I am struggling to find the Message for the switching. The reason why I need the message is because my router can use the usb modems as failover but it fails to install this one, even if it recognise it as E3531/E3276 and I was wondering if I could do anything about this.
Regards
Lila

Author:  LOM [ Mon Mar 12, 2018 7:46 am ]
Post subject:  Re: Huawei E5577Cs-321 - no ttyUSB

lila wrote:
Hello and thank you for all the great work.
I just subscribed because I have a Huawei E5573Cs-322 that should be related to the 5577Cs-321.
I can install it on windows and mac, and it seems to be switching on my openwrt and LEDE virtual machines, but I am struggling to find the Message for the switching. The reason why I need the message is because my router can use the usb modems as failover but it fails to install this one, even if it recognise it as E3531/E3276 and I was wondering if I could do anything about this.


Please provide a verbose lsusb listing for your device so I can see what kind of interfaces it has in default mode.

lsusb -v -d vid:pid

Author:  lila [ Wed Mar 28, 2018 6:13 am ]
Post subject:  Re: Huawei E5577Cs-321 - no ttyUSB

Thank you for your answer and sorry for not posting. I will try to get a way for posting the informations needed, but since I'm on LEDE on a virtual box I seem unable to provide the requested output. I'm going to ask a friend with the same device if they can help me.

Page 1 of 1 All times are UTC+02:00
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/