Author Message

<  Setup Discussion  ~  Confirm E3131 modeswitch to CDC mode?

PostPosted: Tue Nov 26, 2013 5:15 pm Reply with quote
Posts: 14 Joined: Tue Nov 26, 2013 2:11 pm
Hello to everyone! :) I'm new here and I came across this thread while making some research around. Unfortunately, I've read this thread somewhat late...
Here is what has happened. I have a Huawei E3131 and I need to use it on a router. The only way to be able to make the router recognize the modem (with every modem I've used with it, it has always been the same) is to put it in let's say 'modem mode' which in this case is 12d1:1001. What I've made is:

    * Putting it in 'serial mode' (12d1:1442) reaching this address:
    * Sending the AT^U2DIAG=0 command on serial connection through Putty and this gave me 12d1:1c05 (still not recognized by the router as a modem)

After that, I've read here that sending this message content:

usb_modeswitch -W -I -v 12d1 -p 1f01 -V 12d1 -P 1001 -M "55534243123456780000000000000011060000000000000000000000000000"

was enough to achieve what I was looking for so I've tried to restore the dongle back to defaults to start from scratch (I've already tried to send the aforementioned message content with every hardware id I can currently obtain modifying the command accordingly but I couldn't succeed with neither of them, I always get a complaint about something from usb_modeswitch) but when I try to send to it the AT command AT^U2DIAG=119 it reports success but I always get 12d1:14db and not 12d1:1f01. I've also tried the AT^U2DIAG=276 command but I get a reply which states that the command is unsupported by my E3131.
What can I do now? Is it possible that there isn't any way to revert the dongle back to 12d1:1f01? I've made a lot of research around but I couldn't find anything. I hope that someone here could help me. Thanks in advance and have a good day! :)

PostPosted: Wed Nov 27, 2013 8:26 am Reply with quote
Posts: 1175 Joined: Wed Jul 11, 2012 3:14 pm Location: Koh Samui, TH
This is what often happens when tampering with a dongle and you have probably disabled the virtual cd-rom interface which must be enabled for the dongle to come up in initial mode. AT^U2DIAG=255 ought to fix that.

Since you are now back at the 12d1:14db id, then you should also be able to redo the process and stop when you get 12d1:1c05.
"not recognized by the router as a modem" doesn't tell where the problem is and is completely useless info of the same level as "it doesn't work".
12d1:1c05 is an id which should work if you have a fairly recent linux kernel and drivers.

PostPosted: Wed Nov 27, 2013 12:15 pm Reply with quote
Posts: 14 Joined: Tue Nov 26, 2013 2:11 pm
Hi and thanks for your reply. I'll try AT^U2DIAG=255 and post here the results though, I may be wrong, I remember that I've already used that command too and it got refused. I'm surely wrong, what I've already used for sure is AT^U2DIAG=257.
Should that command revert it back to 12d1:1f01 so that I can send the message content later on to obtain 12d1:1001 like other posters from this thread did?
The Linux kernel on the router is very old ( and as explained the only way I have to make the key connect when connected to the usb port of the router is to put it in 12d1:1001 mode which, as you surely know better than me, is the default mode of the older models when zerocd was disabled.
I know what I'm talking about because I've already used many other Huaweis with the router and I know that for sure: putting them in 12d1:1001 mode was the only way to make them work.
When I've previously tried to explain what happens, I meant that the router recognizes the key in 12d1:1c05 mode (while it doesn't in the native 12d1:1f01 one: when the key is in that mode, the router detects only a mass storage device, the zerocd one) but it can't recognize it as a modem, load the appropriate serial driver for it and consequently establish a connection, I don't know what else to say and why you was so upset but I apologize if my attempt at explaining things was poor.
What's sure is that 12d1:1c05 isn't the right mode for my case otherwise I hadn't asked because putting the key in that mode was like a breeze following the simple advices given online (here too).

PostPosted: Thu Nov 28, 2013 12:25 am Reply with quote
Posts: 14 Joined: Tue Nov 26, 2013 2:11 pm
Hello again. There are news, bad ones unfortunately. Probably I remembered well because even with AT^U2DIAG=255 I get +CME ERROR: 50 as response and this means that the command is unsupported according to my research.
What I've done is, while in mode 12d1:14db, going here:

After that, the key goes in mode 12d1:1442 with two serial interfaces available (while when in 12d1:14db I haven't any serial interface available or at least I can't succesfully connect to it) and I can connect to it through Putty but both AT^U2DIAG=255 and AT^U2DIAG=257 (AT^U2DIAG=276 too) are refused; only AT^U2DIAG=119 is accepted and I get 12d1:14db by it. I'm stuck there.
I've read that exactly the same happened to ursus and he was able to go back but he doesn't clearly say how he succeeded in doing it unfortunately.

PostPosted: Sat Dec 07, 2013 12:00 pm Reply with quote
Posts: 14 Joined: Tue Nov 26, 2013 2:11 pm
Is it possible that there isn't anyone apart from ursus who experienced what had happened to me? I had only followed the advices found on the net indeed everything works perfectly fine on a pc (both Linux and Windows ones) but not on my router and it is where I need to use the key which by now is completely useless to me.
The only way to make the key work there is putting it in 12d1:1001 mode and it seems this can be achieved only from the 12d1:1f01 mode which I can't revert back to. Also, I don't understand why the needed message content can be sent only when the key is in 12d1:1f01 mode...
Please help me, I'm sure there is a way to solve things but I can't succeed in finding it in spite of my many attempts and all the research.

PostPosted: Sat Dec 07, 2013 2:27 pm Reply with quote
Posts: 1175 Joined: Wed Jul 11, 2012 3:14 pm Location: Koh Samui, TH
mode switching can only be done from windows install mode (cd-rom mode) to usable mode, your dongle is already in usable mode so it can't be switched again. You don't have to understand why, just accept that it is constructed in that way.

You have disabled the cd-rom and therefore the dongle can not enter install mode, it is locked in usable mode with the id 12d1:14db which only has ethernet interfaces so doesn't accept AT cmds. If you can't enable the cd-rom when the dongle is in serial mode 12d1:1442 then there is not much more you can do.

This is now not a usbmodeswitch problem so you'll have to search for a solution elsewhere since the only thread here about it didn't help you.

PostPosted: Wed Dec 18, 2013 9:05 pm Reply with quote
Posts: 14 Joined: Tue Nov 26, 2013 2:11 pm
I don't understand why you've taken it so personal. I have always been friendly and polite and I've NEVER argued about usbmodeswitch which is instead a great piece of work.
The ONLY reason why I've written here was that ursus had EXACTLY the same problem I have and he solved it with the help from you and Josh. I don't know why I didn't deserve the same help but I apologize should I've done or said anything wrong (though it wasn't my intention). Have a good day.

PostPosted: Fri Apr 21, 2017 12:56 pm Reply with quote
Posts: 14 Joined: Fri Feb 19, 2016 5:40 pm
ursus wrote:
derstand why there was reference to 12d1 1c05 so I decided it is related to some other revision of E3131

now as @LOM suggested I tried AT command
and used AT^U2DIAG=0
now my E3131 is always in 12d1 1c05 mode
I'm relieved to hear that there is at least on E3131 out there, that has a productId of 0x1c05.
Mine seems high level bricked, e.g. raspi sets up ttyUSB[0-2] correctly, but I can't talk to them.

Just to clarify: You sent the AT command to /dev/ttyUSB0, right?
How did you do that?
cu -l ttyUSB0
be ok?

Do I hve to specify a baud rate for that "serial" device?

PostPosted: Fri Apr 21, 2017 9:17 pm Reply with quote
Site Admin Posts: 6436 Joined: Sat Nov 03, 2007 12:30 am
If you are applying permanent changes to your modem with potentially dangerous commands, use at least a real terminal program !!

minicom -D /dev/ttyUSB0 (nothing else, no connection setup or the like)

As the first command, send "ATE1".


Display posts from previous:  Sort by:

All times are UTC+02:00
Page 3 of 3
39 posts
Go to page   Previous 1 2 3
Users browsing this forum: No registered users and 1 guest
Search for:
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum