Author Message

<  Setup Discussion  ~  e3372h - /dev/ttyUSB* are not created

PostPosted: Wed Mar 08, 2017 1:19 pm Reply with quote
Posts: 2 Joined: Wed Mar 08, 2017 12:42 pm
Hello,

I saw the thread at viewtopic.php?f=4&t=2508 but there seems there have not been any answer or activity there for a long time

So I thought I start a new topic with some more information regarding this device

As of now I run the latest versions from the debian-backport repository which is:
usb-modeswitch_2.5.0+repack0-1-bpo8+1_armhf.deb
usb-modeswitch-data_20170120-1-bpo8+1_all.deb

The default mode is 12d1:1f01, with these packages the device gets automatically switched to 12d1:14dc, this gives me access to the eth1 device and the memory storage device
Just like in Windows, If I run dhcp on that interface I will get the IP 192.168.8.100, I will have to setup my default gw and routing but I havn't tried that

If I disable the automatic switching with DisableSwitching=1 in /etc/usb_modeswitch.conf

Then I can switch it manually to 12d1:155e with the following command:
usb_modeswitch -v 0x12d1 -p 0x1f01 -n -I -M 55534243123456780000000000000011063000000100010000000000000000

Which have been said is the fallback mode

This will bring up /dev/ttyUSB0, /dev/ttyUSB1 and /dev/ttyUSB2, but now the block device is gone instead

The problem for me is that I want both the mode which can accept raw AT commands and have access to the micro-sd storage at the same time

But I'm starting to realise there is no such mode available

For me this is sitting on a headless tiny beaglebone black clone and I have been using sakis3g to connect, but sakis3g runs with AT commands



Hope it helps someone, atleast bringing it to fallback mode, I will try to setup all the routing and see if that connects me to the internet, the blue light seems to be on after I run dhcp against it, which indicates it might connect to the world at that point


Offline
PostPosted: Wed Mar 08, 2017 8:25 pm Reply with quote
Site Admin Posts: 6443 Joined: Sat Nov 03, 2007 12:30 am
There is no need to do anything manually, or to disable usb_modeswitch globally.

Just create a custom config file for the modem in "/etc/usb_modeswitch.d", named "12d1:1f01", with this content:
Code:
# Huawei E3372 fallback mode
TargetVendor=0x12d1
TargetProduct=0x155e
MessageContent="55534243123456780000000000000011063000000100010000000000000000"


Offline
PostPosted: Thu Mar 09, 2017 2:48 am Reply with quote
Posts: 1175 Joined: Wed Jul 11, 2012 3:14 pm Location: Koh Samui, TH
salient wrote:

The problem for me is that I want both the mode which can accept raw AT commands and have access to the micro-sd storage at the same time



We can switch to a different composition with the "fallback" switch message but what that composition contains is decided by Huawei in the dongles firmware, we can not change that.
Most of these fallback compositions (12d1:155e included) are intended for dongle firmware update and usually contains 2 serial interfaces, it just so happens that one of the interfaces is connected to the device internal ppp server which means we can use it for dial-up.
There is obviously no use for a storage interface in this debug mode since it is just a temporary mode.

Your problem can easily be fixed by you choosing the right type of dongle for the work you want it to do, there are many Huawei dongles which have the composition you want ie ppp serial dialup + TF/SD storage.
E367, E372, E389 among others, nothing is forcing you to choose a network type dongle.


Offline

Display posts from previous:  Sort by:

All times are UTC+02:00
Page 1 of 1
3 posts
Users browsing this forum: No registered users and 1 guest
Search for:
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum