Author Message

<  Setup Discussion  ~  Huawei E3531 no network interface created

PostPosted: Mon Jun 19, 2017 11:16 pm Reply with quote
Posts: 1Joined: Mon Jun 19, 2017 11:10 pm
I have a Huawei E3531 3G USB modem, i am using usb_modeswitch to make it connect as a serial device and this is working great. However, no network interface is created.

when the modem is converted to a serial device it connects to the internet and creates a session (i can see this using my ISPs remote diagnostic tools). but because a network interface is never created, my Linux box is still without internet. :(

if i wait for about 10 - 15 minutes the modem will eventually disconnect (probably because i have no network interface) and then i can run pppd or wvdial. this will create the ppp0 interface and dial a connection.

How do I make the modem create the ppp0 network interface upon connecting as a serial device? (using usb_modeswitch).

Offline Profile
PostPosted: Tue Jun 20, 2017 6:28 pm Reply with quote
Posts: 1123Location: Koh Samui, THJoined: Wed Jul 11, 2012 3:14 pm
If you don't get any network interface then I'd guess that you don't have the network card driver but only the serial port driver. Your dmesg system log will show you which driver(s) has attached to the device.

Offline Profile

Display posts from previous:  Sort by:

All times are UTC + 1 hour [ DST ]
Page 1 of 1
2 posts
Users browsing this forum: No registered users and 1 guest
Search for:
Post new topic  Reply to topic
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum