Author Message

<  Setup Discussion  ~  Huawei E372 not switching

PostPosted: Mon Nov 26, 2018 10:24 am Reply with quote
Posts: 2 Joined: Mon Nov 26, 2018 10:14 am
Hi,

not sure if I missed anything, but I cannot find the answer on the forums / or google.

I have a Huawei E372 on a Raspberry with Raspbian.
Usb_modeswitch 2.5.0

lsusb:
Code:
Bus 001 Device 007: ID 12d1:14c6 Huawei Technologies Co., Ltd.


--> Seems that it hasn't switched

dmesg | grep 2d
Code:
[    6.564263] usb 1-1.2: New USB device found, idVendor=12d1, idProduct=14c1
[   14.223964] usb 1-1.2: New USB device found, idVendor=12d1, idProduct=14c6
[27446.923842] usb 1-1.2: New USB device found, idVendor=12d1, idProduct=14c1
[27454.604163] usb 1-1.2: New USB device found, idVendor=12d1, idProduct=14c6


--> Seems that it has switched from 14c1 to 14c6

When I try to switch manually from 14c1 it fails, obviously it's already been done:
Code:
$ sudo usb_modeswitch -v 12d1 -p 14c1 -V 12d1 -P 14c6 -R -W -J
Take all parameters from the command line


 * usb_modeswitch: handle USB devices with multiple modes
 * Version 2.5.0 (C) Josua Dietze 2017
 * Based on libusb1/libusbx

 ! PLEASE REPORT NEW CONFIGURATIONS !

DefaultVendor=  0x12d1
DefaultProduct= 0x14c1
TargetVendor=   0x12d1
TargetProduct=  0x14c6
HuaweiNewMode=1

Look for target devices ...
  found USB ID 12d1:14c6
   vendor ID matched
   product ID matched
  found USB ID 0424:ec00
  found USB ID 0424:9514
  found USB ID 1d6b:0002
 Found devices in target mode or class (1)
Look for default devices ...
  found USB ID 12d1:14c6
   vendor ID matched
  found USB ID 0424:ec00
  found USB ID 0424:9514
  found USB ID 1d6b:0002
 No devices in default mode found. Nothing to do. Bye!


So it seems that it has already switched, but it is still recognized as a simple usd storage.
Do you have any idea ? Should I use a different dongle ?

thanks


Offline
PostPosted: Mon Nov 26, 2018 12:36 pm Reply with quote
Posts: 1246 Joined: Wed Jul 11, 2012 3:14 pm Location: Koh Samui, TH
sbe wrote:
So it seems that it has already switched, but it is still recognized as a simple usd storage.


Yes it has already switched so the topic header is wrong.
12d1:14c6 has more interfaces than the storage interface so if you jump to the place in your dmesg which you grepped and read onward from there then you'll see the other interfaces and the drivers being loaded for them.


Offline
PostPosted: Tue Nov 27, 2018 1:37 am Reply with quote
Posts: 2 Joined: Mon Nov 26, 2018 10:14 am
ok then this is strange, as lsusb still returns:

Code:
Bus 001 Device 007: ID 12d1:14c6 Huawei Technologies Co., Ltd.

Even after unplugging - plugging the dongle, or rebooting

As I'm not able to make it connect to internet, I was guessing that the switch was not made properly. I'll investigate further.

thank you for your help


Offline
PostPosted: Thu Nov 29, 2018 12:09 am Reply with quote
Site Admin Posts: 6496 Joined: Sat Nov 03, 2007 12:30 am
It's probably due to some drivers (or driver<-->id associations) missing.


Offline

Display posts from previous:  Sort by:

All times are UTC+02:00
Page 1 of 1
4 posts
Users browsing this forum: No registered users and 1 guest
Search for:
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum