Author Message

<  Setup Discussion  ~  fedora18-raspberrypi3-Huawei E 173

PostPosted: Thu Aug 31, 2017 10:26 am Reply with quote
Posts: 4 Joined: Thu Aug 31, 2017 10:20 am
Hello ..
I have an Raspberry pi 3 with fedora 18 + Huawei E173 . and i installed usb_modswitch 2.5.1 on it .
When connected, the modem will have the following values :
lsusb

# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 009: ID 12d1:1446 Huawei Technologies Co., Ltd. E1552/E1800/E173 (HSPA modem)
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 005: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 004: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB


I dont have any /dev/ttyUSB* !!

I run it and I see : usb_modeswitch -v 12d1 -p 1446 -W
Take all parameters from the command line


* usb_modeswitch: handle USB devices with multiple modes
* Version 2.5.1 (C) Josua Dietze 2017
* Based on libusb1/libusbx

! PLEASE REPORT NEW CONFIGURATIONS !

DefaultVendor= 0x12d1
DefaultProduct= 0x1466

Look for default devices ...
found USB ID 1d6b:0002
found USB ID 12d1:1446
vendor ID matched
found USB ID 0424:ec00
found USB ID 0424:9514
found USB ID 05e3:0608
found USB ID 05e3:0608
No devices in default mode found. Nothing to do. Bye!

How to fix it to see /dev/ttyUSB* ?
Best Regards;


Last edited by hmarei on Fri Sep 01, 2017 4:12 am, edited 1 time in total.

Offline
PostPosted: Thu Aug 31, 2017 4:15 pm Reply with quote
Posts: 1175 Joined: Wed Jul 11, 2012 3:14 pm Location: Koh Samui, TH
hmarei wrote:
I run it and I see : usb_modeswitch -v 12d1 -p 1466 -W


Where does 1466 comes from?


Offline
PostPosted: Thu Aug 31, 2017 8:34 pm Reply with quote
Posts: 4 Joined: Thu Aug 31, 2017 10:20 am
LOM wrote:
hmarei wrote:
I run it and I see : usb_modeswitch -v 12d1 -p 1466 -W


Where does 1466 comes from?

From lsusb response .. See top .


Offline
PostPosted: Fri Sep 01, 2017 3:12 am Reply with quote
Posts: 1175 Joined: Wed Jul 11, 2012 3:14 pm Location: Koh Samui, TH
hmarei wrote:
LOM wrote:
hmarei wrote:
I run it and I see : usb_modeswitch -v 12d1 -p 1466 -W


Where does 1466 comes from?

From lsusb response .. See top .


I can't see any 1466 there, you'd better double check that number. Each digit..


Offline
PostPosted: Fri Sep 01, 2017 4:16 am Reply with quote
Posts: 4 Joined: Thu Aug 31, 2017 10:20 am
Srry . it is my typing problem in forum post. It is 1446 . I give it from lsusb command .

Bus 001 Device 009: ID 12d1:1446 Huawei Technologies Co., Ltd. E1552/E1800/E173 (HSPA modem)


Offline
PostPosted: Fri Sep 01, 2017 9:00 am Reply with quote
Posts: 1175 Joined: Wed Jul 11, 2012 3:14 pm Location: Koh Samui, TH
hmarei wrote:
Srry . it is my typing problem in forum post.


Not only in the forum post.
Look at your usb_modeswitch log, no device found in default mode and the only reason for that is that you have given the product id 1466 on the cmd line.

Use the right value, then usb_modeswitch will be able to switch it.


Offline
PostPosted: Fri Sep 01, 2017 5:45 pm Reply with quote
Posts: 4 Joined: Thu Aug 31, 2017 10:20 am
LOM wrote:
Not only in the forum post.
Look at your usb_modeswitch log, no device found in default mode and the only reason for that is that you have given the product id 1466 on the cmd line.

Use the right value, then usb_modeswitch will be able to switch it.


Oh , OK . Afetr run : usb_modeswitch -v 12d1 -p 1446 -W
I see this message :
Take all parameters from the command line


* usb_modeswitch: handle USB devices with multiple modes
* Version 2.5.1 (C) Josua Dietze 2017
* Based on libusb1/libusbx

! PLEASE REPORT NEW CONFIGURATIONS !

DefaultVendor= 0x12d1
DefaultProduct= 0x1446

Look for default devices ...
found USB ID 1d6b:0002
found USB ID 12d1:1446
vendor ID matched
product ID matched
found USB ID 0424:ec00
found USB ID 0424:9514
found USB ID 05e3:0608
found USB ID 05e3:0608
Found devices in default mode (1)
Access device 012 on bus 001
Get the current device configuration ...
Current configuration number is 1
Use interface number 0
with class 8

USB description data (for identification)
-------------------------
Manufacturer: HUAWEI Technology
Product: HUAWEI Mobile
Serial No.: not provided
-------------------------
Warning: no switching method given. See documentation
-> Run lsusb to note any changes. Bye!

and I checked lsusb again and I see :
Bus 001 Device 012: ID 12d1:1446 Huawei Technologies Co., Ltd. E1552/E1800/E173 (HSPA modem)

And check /dev for ttyUSB* , But there is still a problem and :

ls /dev/ttyUSB*
ls: cannot access /dev/ttyUSB*: No such file or directory

How to solve this problem and access to ttyUSB0-1-2 ...

Best Regards;


Offline
PostPosted: Mon Sep 04, 2017 11:29 am Reply with quote
Site Admin Posts: 6439 Joined: Sat Nov 03, 2007 12:30 am
I'm travelling and can't answer in depth.

"No switching method given" - fix this. Choose huawei-new or huawei-alt. See dmesg output after trying.


Offline
PostPosted: Mon Sep 04, 2017 11:31 am Reply with quote
Site Admin Posts: 6439 Joined: Sat Nov 03, 2007 12:30 am
I suggest you read the WHOLE documentation. See "USB_ModeSwitch" link at the top.


Offline

Display posts from previous:  Sort by:

All times are UTC+02:00
Page 1 of 1
9 posts
Users browsing this forum: No registered users and 2 guests
Search for:
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum