Author Message

<  Setup Discussion  ~  [SOLVED] Huawei usb modem not ever recognized

PostPosted: Sat Sep 16, 2017 11:14 am Reply with quote
Posts: 3 Joined: Sat Sep 16, 2017 11:04 am
Hi, a friend tell me about this forum, because I have a little problem. I try to explain, but I'm a new user in linux.

my usb modem is this:

Code:
Bus 001 Device 010: ID 12d1:14fe Huawei Technologies Co., Ltd. Modem (Mass Storage Mode)


When I insert it in the usb port sometimes is recognized like a usb storage and I can't connect with it.
So I have to give this command:

Code:
sudo usb_modeswitch -v 12d1 -p 14fe -V 12d1 -P 1506 -M 55534243123456780000000000000011060000000000000000000000000000


Sometimes I had to give this command two times and so the usb modem is recognized correctly. After the above command my usb modem is recognized:

Code:
Bus 001 Device 011: ID 12d1:1506 Huawei Technologies Co., Ltd. Modem/Networkcard


How can I do to configure my Linux Mint 18.1 Serena Kde for recognizing immediately my usb modem as a modem?

Thanks


Last edited by mithrandir on Thu Sep 21, 2017 11:52 am, edited 1 time in total.

Offline
PostPosted: Sat Sep 16, 2017 7:28 pm Reply with quote
Site Admin Posts: 6439 Joined: Sat Nov 03, 2007 12:30 am
I'm travelling right now, can't answer in depth.

Please read the documentation (link in top bar), particularly the part about usage and the one about troubleshooting. Enable logging so you can see what your usb_modeswitch installation is doing automatically.


Offline
PostPosted: Sun Sep 17, 2017 4:49 pm Reply with quote
Posts: 3 Joined: Sat Sep 16, 2017 11:04 am
Ok, thank you for your reply, I will try to read and apply the suggestions that you have indicated.


Offline
PostPosted: Thu Sep 21, 2017 11:51 am Reply with quote
Posts: 3 Joined: Sat Sep 16, 2017 11:04 am
Hi Josh,
I fixed the problem compiling the latest version of usb-modeswitch and of usb-modeswitch-data in your site.
I followed the instruction in the README file in the tar.gz downlaoded from the site, but I had to install the libusb-1.0-0-dev package to compile it correctly.
The version of usb-modeswitch that appears in Synaptic is still the 2.2.5, but the usb-modeswitch now works fine, my usb is always recognized as a usb modem.
Cheers


Offline

Display posts from previous:  Sort by:

All times are UTC+02:00
Page 1 of 1
4 posts
Users browsing this forum: No registered users and 1 guest
Search for:
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum