Author Message

<  The PPP Widget Family for Android  ~  PPP Widget - Cyrus China Telecom not working

PostPosted: Mon Oct 08, 2012 7:31 am Reply with quote
Posts: 12 Joined: Mon Oct 08, 2012 6:57 am
Hi, i just joined today and this is my 1st post. First of all, thank you for this great android app, most of my usb modem works, except one, Cyrus China Telecom (0x15eb:7153). From this thread
viewtopic.php?f=4&t=974&hilit=cyrus
via lsusb, i found that the usb switch actually worked (7153 -> 7152), but PPP Widget complained Port wasn't found. Tried to switched to manual mode and assign modem port from /dev/ttyUSB0, USB1 and USB2 but still no luck.

PS: I tested the modem with 2 different tablet, motorola xoom (android 3.2.1) and ainol aurora ii (android 4.0.3) with the latest version of PPP Widget from market


Offline
PostPosted: Mon Oct 08, 2012 10:05 am Reply with quote
Site Admin Posts: 6378 Joined: Sat Nov 03, 2007 12:30 am
This modem is special because it does not have an "interrupt" port - which is the port for connection on all other modems.

There is a report though that the connection will work on ttyUSB0:

https://bugzilla.gnome.org/show_bug.cgi?id=683525#c8
http://bugzilla-attachments.gnome.org/a ... ?id=223838

What is the reply from the widget if you leave the "Device Detection" automatic, and set the "Port Detection" to manual with entering "ttyUSB0" as port?

Do you still get "Port wasn't found" or do you get a different message?


Offline
PostPosted: Mon Oct 08, 2012 10:33 am Reply with quote
Posts: 12 Joined: Mon Oct 08, 2012 6:57 am
I don't have the modem with me atm, i will update as soon as i have it


Offline
PostPosted: Tue Oct 09, 2012 5:01 am Reply with quote
Posts: 12 Joined: Mon Oct 08, 2012 6:57 am
Hi, i already did what you suggested, automatic mode with manual port detection to ttyUSB0, still not working with the same message Port wasn't found. I've tried to change it to USB1 and USB2 also the same


Offline
PostPosted: Wed Oct 10, 2012 12:19 am Reply with quote
Site Admin Posts: 6378 Joined: Sat Nov 03, 2007 12:30 am
Did you check if the "ttyUSB" files actually exist in the "/dev" folder ?

If so, did you enter "ttyUSB0" in the manual field or did you enter "/dev/ttyUSB0"?

There has been a change in this option. Now you are supposed to leave the "/dev/" away.


Offline
PostPosted: Fri Oct 12, 2012 6:28 am Reply with quote
Posts: 12 Joined: Mon Oct 08, 2012 6:57 am
yes, ttyUSB0,1 and 2 exist in /dev, i checked it first before everything else


Offline
PostPosted: Fri Oct 12, 2012 9:11 am Reply with quote
Site Admin Posts: 6378 Joined: Sat Nov 03, 2007 12:30 am
Did you check if you entered "ttyUSB0" in the port field and not "/dev/ttyUSB0"?


Offline
PostPosted: Tue Oct 16, 2012 11:10 am Reply with quote
Posts: 12 Joined: Mon Oct 08, 2012 6:57 am
Josh wrote:
Did you check if you entered "ttyUSB0" in the port field and not "/dev/ttyUSB0"?

Sorry for the late reply. Yes, i did. I tried your suggestion (auto mode, manual port set to ttyUSB0), the PPP Widget stuck at displaying preparing device. Tried both with manual, PPP Widget keep displaying China Telecom altough i already choose it.


Offline

Display posts from previous:  Sort by:

All times are UTC+02:00
Page 1 of 1
8 posts
Users browsing this forum: No registered users and 3 guests
Search for:
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum