Author Message

<  The PPP Widget Family for Android  ~  Driver Modules (obsolete with PPP Widget 2 and 3)

PostPosted: Thu Dec 13, 2012 12:45 am Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
nassus wrote:
Unfortunately I got the same message from "insmod" :(.
And the PPP log looks the same.


There is one thing I don't quite understand. I have the kernel source of the S3's latest update, and it is version 3.0.31 ...

Did you check for an update lately?


Offline
PostPosted: Thu Dec 13, 2012 12:56 am Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
achindra wrote:
Can you please build these binaries for Sony Tablet S running 4.0.4 (Kernel: 2.6.39.4).

My hard drive is running full ...
For every kernel variant I'm creating (which I have to do to retrieve the modules) there are 300 MB gone from the HD space.

I suggest asking at a Sony user's (or developer's) forum. Or - you can do it yourself.


Offline
PostPosted: Thu Dec 13, 2012 8:52 pm Reply with quote
Posts: 10 Joined: Sat Nov 17, 2012 10:59 pm
Josh wrote:
I suggest asking at a Sony user's (or developer's) forum. Or - you can do it yourself.


so why not u make a brief step-by-step tutorial on how we can do this, instead of bothering u making new drivers over and over on every update? :)


Last edited by Michael J on Mon Dec 17, 2012 2:39 pm, edited 2 times in total.

Offline
PostPosted: Sun Dec 16, 2012 6:14 pm Reply with quote
Posts: 6 Joined: Sun Dec 16, 2012 6:09 pm
Hello, could you help me?
and installed ppp widget, but always says modem not found, my kernel is
3.0.31 -523998
is a samsung GT-P5110
version 4.1.1 thanks ...


Offline
PostPosted: Sun Dec 16, 2012 6:47 pm Reply with quote
Posts: 10 Joined: Tue Dec 11, 2012 1:12 pm
Hello Josh,

I know there is a update to Jellybean but I did not want to upgade just yet. Is there a relation between this and the fact that I cannot install the driver?

Thanks.


Offline
PostPosted: Sun Dec 16, 2012 8:43 pm Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
dpunto wrote:
my kernel is 3.0.31 -523998
is a samsung GT-P5110

I have added drivers for this kernel version and name. They are taken from a source tree from a different device though (Galaxy Note II).

If the modules cannot be loaded, I would need one of the modules that came with the system (most likely in "/system/lib/modules").
You can simply attach it to a post here (extension ".ko").


Offline
PostPosted: Sun Dec 16, 2012 8:48 pm Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
nassus wrote:
Is there a relation between this and the fact that I cannot install the driver?

As I said, I have taken the modules from the kernel source which is intended for a different Samsung device. In theory, it should work - the processor type is the same, and the serial USB modules don't have any special system dependencies.

There might be differences in the basic kernel configuration though. To compare the modules, I'd need a module that came with the official system on your device. See reply to dpunto above.


Offline
PostPosted: Sun Dec 16, 2012 10:27 pm Reply with quote
Posts: 6 Joined: Sun Dec 16, 2012 6:09 pm
hello again.
me, to run and put the files in sdcard / pppwidget / lib.
and then entered terminal
and this is the result:
Image


Offline
PostPosted: Sun Dec 16, 2012 10:35 pm Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
dpunto,

as I said, I need one of the modules on your device.


Offline
PostPosted: Sun Dec 16, 2012 11:13 pm Reply with quote
Posts: 6 Joined: Sun Dec 16, 2012 6:09 pm
sorry here I leave the files ..
are copied from system / lib / module


https://dl.dropbox.com/u/27157870/htcmania/P-5110.rar


Offline
PostPosted: Mon Dec 17, 2012 1:00 am Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
dpunto,

can you try once more? I have posted a new module package.


Offline
PostPosted: Mon Dec 17, 2012 9:02 am Reply with quote
Posts: 10 Joined: Tue Dec 11, 2012 1:12 pm
Josh wrote:
nassus wrote:
See reply to dpunto above.


I don't seem to have the "module" folder in /system/lib, can I find the needed files in some other place?


Offline
PostPosted: Mon Dec 17, 2012 10:53 am Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
nassus,

I have updated the driver package for your S3 version. Can you try again?


Offline
PostPosted: Mon Dec 17, 2012 11:32 am Reply with quote
Posts: 10 Joined: Tue Dec 11, 2012 1:12 pm
Ok, something works and something doesn’t. Here is a screenshot. Could I try another usbserial module?
Attachment:
Screenshot_2012-12-17-11-26-13.png
Screenshot_2012-12-17-11-26-13.png [ 121.96 KiB | Viewed 8673 times ]



Offline
PostPosted: Mon Dec 17, 2012 2:38 pm Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
Before you try installing again, issue the command "rmmod" with all of the drivers. In this case, leave the extension out:

# rmmod option

The order is important: option - usb_wwan - usbserial.

For installing the modules reverse this order.

The usbserial module is probably not needed. It may be that this driver is built into the kernel; in that case you can just ignore the errors when loading/unloading.


Offline

Display posts from previous:  Sort by:

All times are UTC+02:00
Page 2 of 9
126 posts
Go to page   Previous 1 2 3 4 59 Next
Users browsing this forum: No registered users and 1 guest
Search for:
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum