Author Message

<  The PPP Widget Family for Android  ~  PPP Widget 2 connected, but no Internet

PostPosted: Tue Apr 12, 2016 10:11 am Reply with quote
Posts: 5 Joined: Sun Dec 29, 2013 12:46 pm
Hello,

PPP Widget 2 detects the USB modem, connects successfuly, but there is actually no Internet connection.

Here is my setup:
ASUS Transformer Prime (tf201) with keyboard dock running custom ROM Android 5.1.1
Rooted: YES -- SuperSU 2.68
BusyBox: YES
USB modem: Huawei E3131

USB Log
Code:
Apr 12, 2016 10:27:06 AM

Device manufacturer string: unknown
New device on /dev/bus/usb/001/003
 Device ID 12d1:15ca
 Device top dir: /sys/bus/usb/devices/1-1.2, active cfg: 1
Device layout (current config) - cl:00  sc:00  pr:ff
 if:0 as:0 -  cl:08  sc:06  pr:50 -  bi:81  bo:01
Preparing to switch mode of USB device 12d1:15ca ...
Device info:
 VID=    12d1
 PID=    15ca
 Manufact.= HUAWEI
   Product= HUAWEI Mobile
Found matching configuration in collection: 12d1.#android
Wait for 800 ms
Bulk message 1: 55534243123456780000000000000011063000000100010000000000000000
  transmitted
New device on /dev/bus/usb/001/004
 Device ID 12d1:1001
 Device top dir: /sys/bus/usb/devices/1-1.2, active cfg: 1
Device layout (current config) - cl:00  sc:00  pr:00
 if:0 as:0 -  cl:ff  sc:ff  pr:ff -  ir:83  bi:82  bo:02
 if:1 as:0 -  cl:ff  sc:ff  pr:ff -  bi:84  bo:03
 if:2 as:0 -  cl:ff  sc:ff  pr:ff -  bi:85  bo:04
Found vendor-specific interface
Load VendorSpec driver, configuration 0
Device ready for modem initialization, using iface 0


PPP Log
Code:
Apr 12, 2016 10:27:17 AM

Start chat sequence for dialling ...
>
ATE0
<
OK
>
AT+CPIN?
<
+CPIN: READY

OK
>
AT+CFUN?
<
+CFUN: 1

OK
>
AT+CGDCONT=1,"IP","internet"
<
OK
>
ATD*99***1#
<
CONNECT
====
Dialling complete


Now start PPP negotiation ...
>
ff03c021010000140206000000000506f7adb02907020802a565
<
ff03c0210101001d08020702020600000000010405dc0506000005430305c223055c67
>
ff03c021030100080304c0232248
<
ff03c021020000140206000000000506f7adb029070208024e0c
<
ff03c0210102001c08020702020600000000010405dc0506000005430304c023692e
>
ff03c0210202001c08020702020600000000010405dc0506000005430304c0235a74
>
c0230101000600003b3f
<
c023020100100b4772656574696e67732121be44
>
802101000016030600000000810600000000830600000000627c
<
802101010004bb99
>
80210201000476bc
<
802103000010810600000000830600000000cb8b
(IPCP Timer up, 1000 ms)
>
8021010100160306000000008106000000008306000000000e4b
<
80210301001603060a87f4398106c1e7fc018306d59a7c011f38
>
80210102001603060a87f4398106c1e7fc018306d59a7c01003b
<
80210202001603060a87f4398106c1e7fc018306d59a7c01f6c8

Local IP: 10.135.244.57
 Peer IP: 10.64.64.64
    DNS1: 193.231.252.1
    DNS2: 213.154.124.1

Send initial IP packet ...
First IP packet received - we are online
PPP negotiation finished


SuperSU Log
Code:
INTERACTIVE
Spwd
setprop ctl.stop ril-daemon
export LD_LIBRARY_PATH=/vendor/lib:/system/lib
ip addr add sit0 10.126.34.178
ip link change dev sit0 mtu 1492
ip link set dev sit0 up
cd /data/local
export CLASSPATH=/data/local/lc.jar
app_process ./ com.android.commands.lc.Lc connected 22 TypeError: 10.126.34.178 10.64.64.64 193.231.252.1 213.154.124.1
./data/data/de.draisberghof.pppwidget2/app_bin
�ip route add default dev tun0 table tun0 2>/dev/null
ip route add default dev tun0 table tun0 2>/dev/null
ip route add default dev tun0 2>/dev/null
6Error: an inet prefix is expected rather than "sit0".
eip route add default dev tun0 table tun0 2>/dev/null
ip route add default dev tun0 2>/dev/null
exit


That inet prefix error stands out.

I also have a full system log recorded with catlog if needed.


Offline
PostPosted: Wed Apr 13, 2016 9:12 am Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
Very good analysis, I can work with that! The logcat output will show not much more information.

Unfortunately I'm quite busy right now; once the situation gets better (weekend) I'll try to follow the error trace that you provided.


Offline
PostPosted: Wed Apr 13, 2016 9:57 am Reply with quote
Posts: 5 Joined: Sun Dec 29, 2013 12:46 pm
Thanks Josh.

Please let me know if you make any progress on this or if I can help in any other way, posting terminal command outputs or whatever.


Offline
PostPosted: Wed Apr 13, 2016 2:10 pm Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
Indeed you can check the default route on the terminal while the connection is up (enter "su" first, but I think you know that).
Code:
# ip route

The result should look similar to this:
Code:
default dev tun0 scope link
100.99.132.0/24 dev tun0 proto kernel scope link src 100.99.132.87

If there is no line with "default", try the following command:
Code:
# ip route add default dev tun0 table tun0


Offline
PostPosted: Thu Apr 14, 2016 12:04 pm Reply with quote
Posts: 5 Joined: Sun Dec 29, 2013 12:46 pm
Looks like your suspicion was correct. ip route did not show any default line and manually adding the default as you suggested fixes the connection issue!

However, after adding the default route manually and doing ip route again, there's still no default line, but the Internet connection does work.

I tried several connects and disconnects without rebooting and I have to re-add the default route every time. Sometimes when I try to add it, I get "RTNETLINK answers: file exists" but the Internet connection does go up.

Hopefully this will help you fix the issue in a new version. Thanks!


Offline
PostPosted: Sun Apr 17, 2016 10:05 pm Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
I have released version 1.5.9 where I cleaned up the many routing commands, some of which were leftovers from early attempts. Not sure if your problem will be solved though.

The default route is set twice, just to be on the safe side; so it doesn't mean there is something wrog if there is a reply after the second call saying "RTNETLINK answers: File exists".

To check if the default route was set properly, the correct command on Lollipop is
Code:
# ip route list table tun0


Offline
PostPosted: Sat Apr 23, 2016 9:09 pm Reply with quote
Posts: 19 Joined: Sat Apr 23, 2016 9:05 pm
I have the same problem.
Samsung Galaxy S4 i9505
Android 4.3
USB Huawei e3372

LOG
23.4.2016 20:51:43

Device manufacturer string: samsung
New device on /dev/bus/usb/002/004
Device ID 12d1:14fe
Device top dir: /sys/bus/usb/devices/2-1, active cfg: 1
Device layout (current config) - cl:00 sc:00 pr:ff
if:0 as:-1 - cl:08 sc:06 pr:50 - bi:81 bo:01
Preparing to switch mode of USB device 12d1:14fe ...
Device info:
VID= 12d1
PID= 14fe
Manufact.= HUAWEI_MOBILE
Product= HUAWEI_MOBILE
Found matching configuration in collection: 12d1.14fe
Wait for 800 ms
Bulk message 1: 55534243123456780000000000000011062000000101000100000000000000
device gone after message 1
New device on /dev/bus/usb/002/005
Device ID 12d1:1506
Device top dir: /sys/bus/usb/devices/2-1, active cfg: 1
Device layout (current config) - cl:00 sc:00 pr:00
if:0 as:-1 - cl:ff sc:02 pr:12 - bi:82 bo:02
if:1 as:-1 - cl:ff sc:02 pr:01 - ir:84 bi:83 bo:03
if:2 as:-1 - cl:ff sc:02 pr:16 - ir:86
if:2 as:-1 - cl:ff sc:02 pr:16 - ir:86 bi:85 bo:04
if:3 as:-1 - cl:08 sc:06 pr:50 - bi:87 bo:05
if:4 as:-1 - cl:08 sc:06 pr:50 - bi:88 bo:06
Found vendor-specific interface
Load VendorSpec driver, configuration 0
Device ready for modem initialization, using iface 1






23.4.2016 20:57:30

Start chat sequence for dialling ...
>
ATE0
<
OK
>
AT+CFUN?
<
+CFUN: 1

OK
>
AT+CGDCONT=1,"IP","internet"
<
OK
>
ATD*99#
<
CONNECT
====
Dialling complete


Now start PPP negotiation ...
>
ff03c021010000140206000000000506f7adb02907020802a565
<
ff03c0210101001d08020702020600000000010405dc05060000054d0305c22305fe5eff03c021020000140206000000000506f7adb029070208024e0c
>
ff03c021030100080304c0232248
<
ff03c0210102001c08020702020600000000010405dc05060000054d0304c023d14f
>
ff03c0210202001c08020702020600000000010405dc05060000054d0304c023e215
>
c0230101000600003b3f
<
c023020100100b4772656574696e67732121be44802101010004bb99
>
802101000016030600000000810600000000830600000000627c
<
802103000010810600000000830600000000cb8b
(IPCP Timer up, 1000 ms)
>
8021010100160306000000008106000000008306000000000e4b
<
8021030100160306644051a181060a3218a083060a3218a18bd3
>
8021010200160306644051a181060a3218a083060a3218a194d0
<
8021020200160306644051a181060a3218a083060a3218a16223

Local
IP: 100.64.81.161
Peer IP: 10.64.64.64

DNS1: 10.50.24.160

DNS2: 10.50.24.161

Send initial IP packet ...
No IP reply for 3 seconds. Just assume we are online
PPP negotiation finished


Please help. Thank you


Offline
PostPosted: Sat Apr 23, 2016 11:57 pm Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
The E3372 does not provide actual PPP ports. It just seems to work ...

If you want, you can participate in the beta test of PPP Widget 2 V2.0.0. which supoorts this modem.
See this thread:
viewtopic.php?f=6&t=2523


Offline
PostPosted: Wed Apr 27, 2016 9:58 am Reply with quote
Posts: 4 Joined: Wed Apr 27, 2016 9:55 am
I'm getting the same thing. (Android 5.1 on Xtrons Car unit)

Start chat sequence for dialling ...
>
ATE0
<
OK
>
AT+CPIN?
<
+CPIN:READY

OK
>
AT+CFUN?
<
+CFUN: 1

OK
>
AT+CGDCONT=1,"IP","giffgaff.com"
<
OK
>
ATD*99#
<
CONNECT 7200000
====
Dialling complete

Now start PPP negotiation ...
>
ff03c021010000140206000000000506f7adb02907020802a565
<
ff03c021011e00190206000000000305c2230505060149177b07020802aa80
>
ff03c021031e00080304c0231fe4
<
ff03c021020000140206000000000506f7adb029070208024e0c
<
ff03c021011f00180206000000000304c02305060149177b07020802b7ae
>
ff03c021021f00180206000000000304c02305060149177b070208027b43
>
c0230101000e0867696666676166660032c1
<
ff03c0210b2000080149177b4995
<
c0230201000500fd30
>
802101000016030600000000810600000000830600000000627c
<
80210300001c81060a0b0c0d83060a0b0c0e82060a0b0c0d84060a0b0c0e0951
>
80210101002203060000000081060a0b0c0d82060a0b0c0d83060a0b0c0e84060a0b0c0efcc6
<
80210301001c81060a0b0c0d83060a0b0c0e82060a0b0c0d84060a0b0c0e4103
>
80210102002203060000000081060a0b0c0d82060a0b0c0d83060a0b0c0e84060a0b0c0e5906
<
8021011200044af3
>
80210212000487d6
<
80210402001082060a0b0c0d84060a0b0c0eb20a
<
80210113000496a9
>
8021021300045b8c
(IPCP Timer up, 1000 ms)
>
80210103001603060000000081060a0b0c0d83060a0b0c0e871d
<
80210303001603060a90e7e381065284fe0283065284fe03229b
>
80210104001603060a90e7e381065284fe0283065284fe038d45
<
80210204001603060a90e7e381065284fe0283065284fe037bb6

Local IP: 10.144.231.227
Peer IP: 10.64.64.64
DNS1: 82.132.254.2
DNS2: 82.132.254.3

Send initial IP packet ...
First IP packet received - we are online
PPP negotiation finished

But then just no internet access.


Offline
PostPosted: Wed Apr 27, 2016 12:46 pm Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
stevellion,

I think your's is the same problem as Skello's, but not the same as mclareniak's. Note the difference in the log:

First IP packet received - we are online

versus

No IP reply for 3 seconds. Just assume we are online

The latter comes from a modem that does not actually connect. The former indicates that the connection was made successfully, however afterwards there is a problem with the setting of the network route. In that case, the immediate remedy is what I suggested to Skello.


Offline
PostPosted: Wed Apr 27, 2016 1:41 pm Reply with quote
Posts: 4 Joined: Wed Apr 27, 2016 9:55 am
Indeed, my thoughts too as the same issue.

My complication is that I'm using an in-car Android head unit, so connecting with terminal and doing some more commands might be a bit distracting from driving :-)

So - hoping the beta/test version can address this with your support.

Thanks


Offline
PostPosted: Wed Apr 27, 2016 9:17 pm Reply with quote
Posts: 4 Joined: Wed Apr 27, 2016 9:55 am
Indeed, Alpha 4 does not solve this problem - but the positive news is it behaves equally well in getting to the same point.

Connection made, but no internet.
I'm getting DNS error : net::ERR_NAME_NOT_RESOLVED : so this would indeed tie in with no default route as discussed above.


Offline
PostPosted: Wed Apr 27, 2016 10:33 pm Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
Alpha 5 is on the way as we speak.

I've introduced an experimental change regarding the network route.
At least it does not affect my devices (all working) adversely ...


Offline
PostPosted: Fri Jul 21, 2017 9:13 pm Reply with quote
Posts: 7 Joined: Fri Jul 21, 2017 9:01 pm
Hi,

I have same problem and same errors like Skello


my setup:

Rooted: YES
BusyBox: NO
USB modem: ZTE MF 626, CD_STARTUP_FLAG and FLAG_NO_DOWNLOAD disabled

Image

when i try PPP widget 2 my ip route looks like

Code:
100.99.132.0/24 dev tun0 proto kernel scope link src 100.99.132.87

i tried add ip route add default dev tun0 table tun0
but nothing changed

After that i`ve tried PPP widget 3
Image
ip route there is empty, noting can do with it

Is it problem with my device or with modem?


Offline
PostPosted: Sat Jul 22, 2017 1:36 pm Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
Are you running SuperSU as the root app? Others are probably not compatible with PPP Widget 3.

Also note that PPP Widget 2 is not maintained anymore. Try again with PPP Widget 3, I have just released an update.


Offline

Display posts from previous:  Sort by:

All times are UTC+02:00
Page 1 of 2
27 posts
Go to page 1 2 Next
Users browsing this forum: No registered users and 1 guest
Search for:
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum
cron