Author Message

<  The PPP Widget Family for Android  ~  support for D link DWM 221

PostPosted: Sun Dec 11, 2016 5:41 pm Reply with quote
Posts: 1 Joined: Sun Dec 11, 2016 4:44 pm
I bought D-LINK DWM-221 LTE modem but sadly this modem is not recognized by PPP Widget 3.
how can i make this modem work ?
thanks


Offline
PostPosted: Sun Dec 11, 2016 11:35 pm Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
Please post the "USB Log" - and the "PPP Log" if there is one - from PPP Widget 3. I need to see the details of your modem's ports.

To get that log, enable the "Logging" option in the configuration and attach your modem again.

Be so kind and post it as text, not as a screenshot or a photo.


Offline
PostPosted: Mon Jan 29, 2018 9:15 pm Reply with quote
Posts: 1 Joined: Mon Jan 29, 2018 9:13 pm
Josh wrote:
Please post the "USB Log" - and the "PPP Log" if there is one - from PPP Widget 3. I need to see the details of your modem's ports.

To get that log, enable the "Logging" option in the configuration and attach your modem again.

Be so kind and post it as text, not as a screenshot or a photo.




Hi. I have this modem, too. follows the usb log:



29/01/2018 16:08:41

Device manufacturer string: LGE
Start manual search for USB devices
on kernel level ...
Found possible modem device 2001:a401
Device not in initial mode; API bus search may detect it
No known modem found in install mode
Start search for USB devices
visible on Android OS level ...
Check device 2001:a401, interface 8, might be a modem
Found possible 3G USB device 2001:a401
New device on /dev/bus/usb/001/002
Class of interface 0 is 0x08
Looking at USB device 2001:a401 with class 8
Device top dir: /sys/bus/usb/devices/1-1, active cfg: 1
Active configuration ID: 1
Device layout (config 1) - cl:00 sc:00 pr:00
if:0 as:0 - cl:08 sc:06 pr:50 - bi:81 bo:01

Found 0 serial ports
No dedicated modem port found
Preparing to switch mode of USB device 2001:a401 ...
Device info:
VID= 2001
PID= a401
Manufact.= Mobile Connect
Product= Mobile Connect
Found matching configuration in collection: 2001.a401
Wait for 200 ms
Bulk message 1: 5553424312345678000000000000061e000000000000000000000000000000
transmitted
Bulk message 2: 5553424312345679000000000001061b000000010000000000000000000000
transmitted
Bulk message 3: 5553424312345670000000000000061b000000020000000000000000000000
transmitted
No modem device found after mode switch
Mode-switching procedure finished

Thank you.


Offline
PostPosted: Tue Jan 30, 2018 8:41 am Reply with quote
Posts: 1166 Joined: Wed Jul 11, 2012 3:14 pm Location: Koh Samui, TH
It looks like there is a bug in the implementation of "StandardEject" in pppwidget, bulk message 2 is wrong and there is a missing message as well.

The right sequence is:

5553424387654321000000000000061e000000000000000000000000000000
5553424397654321000000000000061b000000020000000000000000000000

5553424387654321000000000001061e000000000000000000000000000000
5553424397654321000000000001061b000000020000000000000000000000


Josh!!


Offline
PostPosted: Mon Feb 05, 2018 9:48 pm Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
I've failed to notice your response, LOM ...

Anyway, I have checked - the problem is with the individual config file which doesn't use StandardEject but rather this special (and likely wrong) sequence. The StandardEject sequence contains the messages you listed.

Update in making ...


Offline

Display posts from previous:  Sort by:

All times are UTC+02:00
Page 1 of 1
5 posts
Users browsing this forum: No registered users and 2 guests
Search for:
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum