Author Message

<  The PPP Widget Family for Android  ~  Hp 820g1 laptop with RemixOs and Hp4112(HUAWEI ME906E) modem

PostPosted: Fri Mar 10, 2017 5:12 pm Reply with quote
Posts: 5 Joined: Fri Mar 10, 2017 3:23 pm
Hy
i have remixos installated on hp laptop hp 820g1. It has internal modem pci-e hp 4112 (HUAWEI ME906E).
I have download ppp version 3, installed it and add widget. it ask me for root access and i get it.
next ppp widget 3 ask me for open this usb device when is connected. i sign ok.
widget star and show modem status and signal strenght.
next i open configuration and when i click on edit current sim profile it show me
to close configuration and insert modem first. close configuration
i remove and re-put widget on the drawer but it show me
no modem found!
can you help me?


thanks and sorry for my english
Attachments:
CIMG3544.JPG
CIMG3544.JPG [ 24.29 KiB | Viewed 1912 times ]

Offline
PostPosted: Sat Mar 11, 2017 8:30 pm Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
[I have removed two of your screen shots - they are not really relevant]

First thing: I'm not sure that an internal pcie modem will ever work; this is totally untested.

Second thing: I need to see the "USB Log" from PPP Widget 3.

For this, enable the logging option in the configuration (go to the bottom). Then - while the display says "no modem found - touch the icon of PPP Widget 3 so that it starts the manual search for modems.

Now open the configuration again and press the button "USB Log". Copy the text that is shown and post it here.

Please post it as text, not as image.


Offline
PostPosted: Sun Mar 12, 2017 1:20 am Reply with quote
Posts: 1166 Joined: Wed Jul 11, 2012 3:14 pm Location: Koh Samui, TH
Josh wrote:
I'm not sure that an internal pcie modem will ever work; this is totally untested.



Internal pcie modem is like any other usb modem.
The form factor/connector is pcie but uses only the power pins and the two usb data pins within the connector.

The device will have two or three configurations (depending of which firmware it has), qmi+ppp, mbim or qmi+ppp, ecm, mbim.
No virtual cd-rom install mode.


Offline
PostPosted: Wed Mar 15, 2017 3:39 pm Reply with quote
Posts: 5 Joined: Fri Mar 10, 2017 3:23 pm
Thank You for your quick support!
this is the log:
PPP

Mar 15, 2017 12:55:05 PM

Device manufacturer string: Hewlett-Packard
New device on /dev/bus/usb/002/005
Class of interface 0 is 0xFF
Looking at USB device 03f0:581d with class 255
Device top dir: /sys/bus/usb/devices/2-6, active cfg: 2
Active configuration ID: 2
Device layout (config 2) - cl:00 sc:00 pr:00
if:0 as:0 - cl:02 sc:06 pr:00 - ir:82
if:1 as:0 - cl:0a sc:00 pr:00 -
if:1 as:1 - cl:0a sc:00 pr:00 - bi:81 bo:01
if:2 as:0 - cl:ff sc:01 pr:03 - bi:83 bo:02
if:3 as:0 - cl:ff sc:01 pr:02 - bi:84 bo:03
if:4 as:0 - cl:ff sc:01 pr:05 - bi:85 bo:04

Found 3 serial ports
Disable kernel USB power-save, as set in app config
Opening port type ECM
Could not read descriptor for MAC address - result: -1
MAC idx: 11, raw descriptor: byteArrayToString: no data!
Trying to continue, use made-up MAC


Offline
PostPosted: Wed Mar 15, 2017 10:40 pm Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
Hmm, I may have to work on the app ...

Creating a mandatory SIM profile makes no sense in ECM mode where everything is controlled via the browser interface.

Stand by for an update.


Offline
PostPosted: Thu Mar 16, 2017 11:24 am Reply with quote
Posts: 5 Joined: Fri Mar 10, 2017 3:23 pm
Thank You Very Much!
If you want i can pay for this app! thanks!


Offline
PostPosted: Thu Mar 16, 2017 8:12 pm Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
I just checked the source code - the profile is not required if a modem like your's is connected.

So don't try to edit the profile at all - just hit "Connect". I will add some lines to the code that prevent opening the profile editor if an ECM modem is connected.

If you ever see "No modem" displayed , just touch the icon at the left side of PPP Widget, and it will start a search for modems and hopefully find your's again.


Offline
PostPosted: Fri Mar 24, 2017 5:51 pm Reply with quote
Posts: 5 Joined: Fri Mar 10, 2017 3:23 pm
Hi,
thank you for your support. The problem is that the application works only the first time. if i reboot
and click on icon they show "no modem found". This is the log:

Mar 24, 2017 3:07:12 PM

Device manufacturer string: Hewlett-Packard
Start manual search for USB devices
on kernel level ...
No known modem found in install mode
Start search for USB devices
visible on Android OS level ...
Check device 03f0:581d, interface 2, might be a modem
No known 3G USB device found
Search complete, no useable USB devices found.

Thank You!


Offline
PostPosted: Sat Mar 25, 2017 10:45 am Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
I'll have a look later on - for now I'm out of the loop due to some travelling. Please stand by.


Offline
PostPosted: Fri Jun 22, 2018 2:58 pm Reply with quote
Posts: 5 Joined: Fri Mar 10, 2017 3:23 pm
Good morning!
any news? i have updated to last version but doesen't work.thanks!


Offline
PostPosted: Fri Jun 22, 2018 11:03 pm Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
Oh, sorry - I must have thrown this out of my memory during my vacation ...

Googling that device ID (03f0:581d) I found that this may be a QMI device (this is a special set-up protocol for the ethernet interface). That would explain why it didn't work as ECM.

These QMI devices are not detectable by a certain interface layout; I have to consult a list with all sorts of devices and parameters, and devices missing on that list are not detected.

I can just add it in a new release and we'll see how this works out. Some time during the week-end.


Offline
PostPosted: Sat Jun 23, 2018 6:02 am Reply with quote
Posts: 1166 Joined: Wed Jul 11, 2012 3:14 pm Location: Koh Samui, TH
There has been a couple of users reporting problem with the cdc_ether interface in config#2 but I don't think their solution was to talk qmi on that interface, they probably selected config#1 which has a rmnet/qmi interface.

cfg #1
MI_00 HP lt4112 Gobi 4G Module PC UI
MI_01 HP lt4112 Gobi 4G Module Application
MI_02 HP lt4112 Gobi 4G Module Modem
MI_03 HP lt4112 Gobi 4G Module Network Device (qmi_wwan)
MI_04 HP lt4112 Gobi 4G Module NMEA

cfg#2
MI_00 HP lt4112 Gobi 4G Module Network Device (cdc_ether)
MI_02 HP lt4112 Gobi 4G Module Application
MI_03 HP lt4112 Gobi 4G Module PC UI
MI_04 HP lt4112 Gobi 4G Module NMEA

cfg#3
MI_00 HP lt4112 Gobi 4G Module Network Device (cdc_mbim)
MI_02 HP lt4112 Gobi 4G Module NMEA

or the older firmware:

cfg #1
MI_00 HP lt4112 Gobi 4G Module PC UI
MI_01 HP lt4112 Gobi 4G Module Application
MI_02 HP lt4112 Gobi 4G Module Modem
MI_03 HP lt4112 Gobi 4G Module SCard
MI_04 HP lt4112 Gobi 4G Module Network Device (qmi_wwan)
MI_05 HP lt4112 Gobi 4G Module NMEA

cfg#2
MI_00 HP lt4112 Gobi 4G Module Network Device (cdc_mbim)
MI_02 HP lt4112 Gobi 4G Module NMEA


Offline
PostPosted: Sat Jun 23, 2018 9:26 am Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
I just have actually looked at the QMI table included with PPP Widget, and found the device there. So it's already listed as a QMI device.

I also have discovered that the configuration file for the modem preparation (the "mode switch") for this modem is bogus. I've included the configurations taken from "usb_modeswitch", only slightly truncated by a script; however, some modems - inluding most HPs - are prepared according to driver availability on the host system.

That obviously doesn't work on Android, so I have to alter the PPP Widget configuration files for these modems.

@LOM:

The Linux kernel seems to support the QMI mode for devices with this ID, so I think it's worth a try if the other mode causes trouble.

https://patchwork.kernel.org/patch/7681261/


Offline
PostPosted: Sun Jun 24, 2018 10:54 pm Reply with quote
Site Admin Posts: 6420 Joined: Sat Nov 03, 2007 12:30 am
The update should be available now. If you want, try again with your modem.


Offline

Display posts from previous:  Sort by:

All times are UTC+02:00
Page 1 of 1
14 posts
Users browsing this forum: No registered users and 1 guest
Search for:
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum