Author Message

<  The PPP Widget Family for Android  ~  No Internet Connectivity with PPP Widget

PostPosted: Mon Apr 17, 2017 1:09 pm Reply with quote
Posts: 7 Joined: Mon Apr 17, 2017 12:29 pm
I have installed the latest PPP Widget and using it on my Android Car Unit, current OS is Android 5.1.1, when I use the PPP Widget with the ZTE K5006-Z modem, the modem says connected on the widget, and the light on the modem is solid, however I get no internet traffic of any nature.
All I get is a key symbol at the top of the screen where the connection strength and type of connection would normally show.
If any additional information is needed to help solve my problem, please let me know what to supply.

I do not know if I am doing something wrong, or if the modem I am using or OS is not compatible.

Any form of assistance would be greatly appreciated.


Offline
PostPosted: Mon Apr 17, 2017 7:08 pm Reply with quote
Site Admin Posts: 6439 Joined: Sat Nov 03, 2007 12:30 am
Please retrieve the USB log and the PPP log from PPP Widget (latest version).
Enable the logging option (bottom of the config page), then re-plug the modem and connect.

Post the logs as text, either embedded in a post or as attachment. This will show us the necessary information about the modem and the connection.


Offline
PostPosted: Mon Apr 17, 2017 8:30 pm Reply with quote
Posts: 7 Joined: Mon Apr 17, 2017 12:29 pm
Here is the USB and PPP log separated by the XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

USB Log

Device manufacturer string: rockchip
Start search for USB devices
visible on Android OS level ...
Check device 05e3:0752, interface 8, might be a modem
Check device 19d2:1017, interface 8, might be a modem
Found possible 3G USB device 19d2:1017
New device on /dev/bus/usb/001/003
Class of interface 0 is 0x08
Looking at USB device 19d2:1017 with class 8
Device top dir: /sys/bus/usb/devices/1-1, active cfg: 1
Device layout (config 1) - cl:00 sc:00 pr:00
if:0 as:0 - cl:08 sc:06 pr:50 - bo:01 bi:81

Found 0 serial ports
No dedicated modem port found
Preparing to switch mode of USB device 19d2:1017 ...
Device info:
VID= 19d2
PID= 1017
Manufact.= ZTE,Incorporated
Product= ZTE LTE Technologies MSM
Found matching configuration in collection: 19d2.1017
Wait for 200 ms
Bulk message 1: 5553424387654321000000000000061e000000000000000000000000000000
transmitted
Bulk message 2: 5553424397654321000000000000061b000000020000000000000000000000
transmitted
Bulk message 3: 5553424387654321000000000001061e000000000000000000000000000000
transmitted
New device on /dev/bus/usb/001/004
Class of interface 0 is 0xFF
Looking at USB device 19d2:1018 with class 255
Device top dir: /sys/bus/usb/devices/1-1, active cfg: 1
Device layout (config 1) - cl:00 sc:00 pr:00
if:0 as:0 - cl:ff sc:86 pr:10 - bi:81 bo:01
if:1 as:0 - cl:ff sc:02 pr:05 - bi:82 bo:02
if:2 as:0 - cl:ff sc:02 pr:01 - ir:83 bi:84 bo:03
if:3 as:0 - cl:ff sc:06 pr:00 - ir:85 bi:86 bo:04
The table says these values define a QMI port
if:4 as:0 - cl:08 sc:06 pr:50 - bo:05 bi:87

Found 3 serial ports
Opening port type QMI
No MAC descriptor found, use made-up MAC

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

PPP Log

Starting modem command sequence ...
>
010f0000000000082200040001010001
<
011700800000010822000c00020400000000000102000101
>
01270000010100020020001b0017050067756573741805006775657374140800696e7465726e6574
<
011f008001010202002000130002040001000e0010020003001104000300d107
>
01270000010100030020001b0017050067756573741805006775657374140800696e7465726e6574
<
011f008001010203002000130002040001000e0010020003001104000300d107
>
01270000010100040020001b0017050067756573741805006775657374140800696e7465726e6574
<
011f008001010204002000130002040001000e0010020003001104000300d107
>
01270000010100050020001b0017050067756573741805006775657374140800696e7465726e6574
<
011f008001010205002000130002040001000e0010020003001104000300d107
>
01270000010100060020001b0017050067756573741805006775657374140800696e7465726e6574
<
011f008001010206002000130002040001000e0010020003001104000300d107
>
01270000010100070020001b0017050067756573741805006775657374140800696e7465726e6574
<
015500800301040000240049002905008f02010000250200936522050002030000001e04001e97d8->
041d02003d80190100011503000108011209008f02010004564f4441110200010b10010001010600->
010101020108
<
013200800301040000240026002905008f020100001209008f02010004564f4441110200010b10010->
001010600010101020108
>
010c00000301000b0020000000
<
011800800301020b0020000c0002040000000000010200c008
<
011a0080010102070020000e000204000000000001040090352502
>
0113000001010008002d00070010040010a30000
<
0115008001ff04000022000900010200020012010004
<
0141008001010208002d003500020400000000001e040081156d64150400fb24cfc4160400fe24cfc4->
20040082156d64210400fcffffff290400dc0500002b010004
Local IP: 100.109.21.129/24
Peer IP: 100.109.21.130
DNS1: 196.207.36.251
DNS2: 196.207.36.254
====
Connection is up (raw IP)

Android VPN creation complete
VPN network device is up


Offline
PostPosted: Mon Apr 17, 2017 9:15 pm Reply with quote
Site Admin Posts: 6439 Joined: Sat Nov 03, 2007 12:30 am
Is that the latest version of PPP Widget 3?

I'm missing the report of the "network notification" ...
It is expected to look like this
Code:
Network notification seems to have failed
 limited network access.

or this
Code:
Network notification succeeded after 500 ms


Offline
PostPosted: Mon Apr 17, 2017 9:43 pm Reply with quote
Posts: 7 Joined: Mon Apr 17, 2017 12:29 pm
Hello Josh

Yes it is the latest version of PPP Widget 3, I downloaded it and installed it to the the test you required.

I installed the PPP. plugged modem in.
Configured the settings
Rebooted the unit.
Then connected.
Let it run for a while, tried one or 2 apps to check for connectivity.
Then disconnected to gain access to the logs.
and sent logs off to you.

Is there something else I could have done? or should have tried?


Offline
PostPosted: Mon Apr 17, 2017 10:05 pm Reply with quote
Posts: 7 Joined: Mon Apr 17, 2017 12:29 pm
Josh

I did it again, and this is what I got.

USB Log

Apr 17, 2017 9:51:36 PM

Device manufacturer string: rockchip
New device on /dev/bus/usb/001/005
Class of interface 0 is 0x08
Looking at USB device 19d2:1017 with class 8
Device top dir: /sys/bus/usb/devices/1-1, active cfg: 1
Device layout (config 1) - cl:00 sc:00 pr:00
if:0 as:0 - cl:08 sc:06 pr:50 - bo:01 bi:81

Found 0 serial ports
No dedicated modem port found
Preparing to switch mode of USB device 19d2:1017 ...
Device info:
VID= 19d2
PID= 1017
Manufact.= ZTE,Incorporated
Product= ZTE LTE Technologies MSM
Found matching configuration in collection: 19d2.1017
Wait for 200 ms
Bulk message 1: 5553424387654321000000000000061e000000000000000000000000000000
transmitted
Bulk message 2: 5553424397654321000000000000061b000000020000000000000000000000
transmitted
Bulk message 3: 5553424387654321000000000001061e000000000000000000000000000000
transmitted
New device on /dev/bus/usb/001/006

Class of interface 0 is 0xFF
Looking at USB device 19d2:1018 with class 255
Device top dir: /sys/bus/usb/devices/1-1, active cfg: 1
Device layout (config 1) - cl:00 sc:00 pr:00
if:0 as:0 - cl:ff sc:86 pr:10 - bi:81 bo:01
if:1 as:0 - cl:ff sc:02 pr:05 - bi:82 bo:02
if:2 as:0 - cl:ff sc:02 pr:01 - ir:83 bi:84 bo:03
if:3 as:0 - cl:ff sc:06 pr:00 - ir:85 bi:86 bo:04
The table says these values define a QMI port
if:4 as:0 - cl:08 sc:06 pr:50 - bo:05 bi:87

Found 3 serial ports
Opening port type QMI
No MAC descriptor found, use made-up MAC

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

PPP Log

Apr 17, 2017 9:51:56 PM

Starting modem command sequence ...
>
010f0000000000092200040001010001
<
011700800000010922000c00020400000000000102000101
>
01270000010100020020001b0017050067756573741805006775657374140800696e7465726e6574
<
011a0080010102020020000e000204000000000001040090352502
>
0113000001010003002d00070010040010a30000
<
0115008001ff04000022000900010200020012010004
<
0141008001010203002d003500020400000000001e0400e7fc6e64150400fb24cfc4160400fe24cfc42->
00400e1fc6e64210400f0ffffff290400dc0500002b010004
Local IP: 100.110.252.231/24
Peer IP: 100.110.252.225
DNS1: 196.207.36.251
DNS2: 196.207.36.254
====
Connection is up (raw IP)

Android VPN creation complete
VPN network device is up


Offline
PostPosted: Tue Apr 18, 2017 9:19 pm Reply with quote
Site Admin Posts: 6439 Joined: Sat Nov 03, 2007 12:30 am
I'm working on an update which should indicate the 'network notification' thing more clearly.
Please stand by (for a day or two) ...


Offline
PostPosted: Tue Apr 18, 2017 9:33 pm Reply with quote
Posts: 7 Joined: Mon Apr 17, 2017 12:29 pm
Thank you.


Offline
PostPosted: Wed Apr 19, 2017 9:42 pm Reply with quote
Site Admin Posts: 6439 Joined: Sat Nov 03, 2007 12:30 am
The update is ready. It may take some moments to become available on Google Play though.

Be so kind and post the PPP log from this new version.


Offline
PostPosted: Thu Apr 20, 2017 6:26 am Reply with quote
Posts: 7 Joined: Mon Apr 17, 2017 12:29 pm
Hello Josh

Thank you for the speedy reply, I get my car back this weekend so please give me till then to do the tests for you.

Thank you
Jeff


Offline
PostPosted: Sun Apr 23, 2017 11:03 am Reply with quote
Posts: 7 Joined: Mon Apr 17, 2017 12:29 pm
Hello Josh

here are the new logs

PPP

PPP

Apr 23, 2017 10:19:27 AM

Starting modem command sequence ...
>
010f0000000000092200040001010001
<
011700800000010922000c00020400000000000102000101
>
01270000010100020020001b0017050067756573741805006775657374140800696e7465726e6574
<
013200800301040000240026002905008f020100001209008f02010004564f4441110200010b10010->
001010600010101020108
<
011a0080010102020020000e000204000000000001040090352502
>
0113000001010003002d00070010040010a30000
<
0115008001ff04000022000900010200020012010004
<
0141008001010203002d003500020400000000001e0400f5286d64150400fb24cfc4160400fe24cfc42->
00400f6286d64210400fcffffff290400dc0500002b010004
Local IP: 100.109.40.245/24
Peer IP: 100.109.40.246
DNS1: 196.207.36.251
DNS2: 196.207.36.254
====
Connection is up (raw IP)

Android VPN creation complete
VPN network device is up
* I/O error during network setup: java.io.IOException: write failed: EPIPE (Broken pipe)

USB

Apr 23, 2017 10:30:40 AM

Device manufacturer string: rockchip
Start search for USB devices
visible on Android OS level ...
Check device 05e3:0752, interface 8, might be a modem
Check device 12d1:1001, interface 2, might be a modem
Found possible 3G USB device 12d1:1001
New device on /dev/bus/usb/001/003
Class of interface 0 is 0xFF
Looking at USB device 12d1:1001 with class 255
Device top dir: /sys/bus/usb/devices/1-1, active cfg: 1
Could not open USB device!
Aborting modem initialization

The Widget indicated that it was connected.

Jeff


Offline
PostPosted: Sun Apr 23, 2017 1:07 pm Reply with quote
Site Admin Posts: 6439 Joined: Sat Nov 03, 2007 12:30 am
Ahaa - that error is the reason why the network setup is never completed on your device !

Unfortunately, I don't know exactly what to make of it - never saw this before ...

First, let's double-check your environment. I suppose you have the "SuperSU" app installed (which is required for PPP Widget ).
Now get the free app "Android Terminal Emulator" and launch it. Adjust the text size if the default is too small.
In the terminal window, you should see a prompt ending with "$". Now type "su" and enter.

There should be a prompt by "SuperSU" to approve the root request (if you haven't done all this before).

If you don't hit any bumps in the process, we need to dig deeper. You need the app "Catlog". Once installed, connect PPP Widget again. Immediately afterwards, open Catlog and save the complete system log to a file. Post it here (zip it if possible.


Offline
PostPosted: Fri May 12, 2017 8:11 am Reply with quote
Posts: 4 Joined: Fri May 12, 2017 7:46 am
//THIS CAN BE DELETED


Last edited by mobi on Sun May 14, 2017 7:57 am, edited 1 time in total.

Offline
PostPosted: Sat May 13, 2017 1:17 pm Reply with quote
Posts: 65 Joined: Sun Jul 17, 2016 11:32 am
Hello, you should open a new post. And before any system logs it is good to post the PPP log.


Offline

Display posts from previous:  Sort by:

All times are UTC+02:00
Page 1 of 1
14 posts
Users browsing this forum: Baidu [Spider] and 1 guest
Search for:
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum