Author Message

<  The PPP Widget Family for Android  ~  Modem status Connected but no internet connection

PostPosted: Mon Dec 18, 2017 4:22 pm Reply with quote
Posts: 3Joined: Mon Dec 18, 2017 4:05 pm
HEllo,
I tried to connect unlocked Huawei E352 3G modem with H96 pro+ TV box with Android 7.1.2 rooted with different telco providers (and telco settings of course).
The modem successfully found, connects (LED always blue) but unfortunately there is no internet connection on any app. VPN symbol lights on upper task bar.


There is USB log
Quote:
11 дек. 2017 г. 17:34:08

Device manufacturer string: Amlogic
New device on /dev/bus/usb/001/010
Class of interface 0 is 0x08
Looking at USB device 12d1:1446 with class 8
Device top dir: /sys/bus/usb/devices/1-3.3, active cfg: 1
Device layout (config 1) - cl:00 sc:00 pr:00
if:0 as:0 - cl:08 sc:06 pr:50 - bi:81 bo:01
if:1 as:0 - cl:08 sc:06 pr:50 - bo:02 bi:82

Preparing to switch mode of USB device 12d1:1446 ...
Device info:
VID= 12d1
PID= 1446
Manufact.= Huawei Technologies
Product= HUAWEI Mobile
Found matching configuration in collection: 12d1.#android
Wait for 200 ms
Bulk message 1: 55534243123456780000000000000011063000000100010000000000000000
transmitted
New device on /dev/bus/usb/001/011
Class of interface 0 is 0xFF
Looking at USB device 12d1:1506 with class 255
Device top dir: /sys/bus/usb/devices/1-3.3, active cfg: 1
Device layout (config 1) - cl:00 sc:00 pr:00
if:0 as:0 - cl:ff sc:01 pr:01 - ir:81 bi:82 bo:01
if:1 as:0 - cl:ff sc:01 pr:07 - ir:83 bi:84 bo:02
The table says these values define a QMI port
if:2 as:0 - cl:ff sc:01 pr:03 - bi:85 bo:03
if:3 as:0 - cl:ff sc:01 pr:02 - bi:86 bo:04
if:4 as:0 - cl:08 sc:06 pr:50 - bi:87 bo:05
if:5 as:0 - cl:08 sc:06 pr:50 - bo:06 bi:88

Opening port type QMI
No MAC descriptor found, use made-up MAC


and PPP-log

Quote:
11 дек. 2017 г. 17:34:40

Starting modem command sequence ...
>
010f0000000000062200040001010001
<
011700800000010622000c00020400000000000102000101
>
01200000010100010020001400141100696e7465726e65742e74656c65322e7275
<
011a0080010102010020000e0002040000000000010400c0aafc00
>
0113000001010002002d00070010040010a30000
<
0115008001ff04000022000900010200020012010004
<
0141008001010202002d003500020400000000001e0400eeea6c0a1504000904dc0a1604000904dd0a200400edea6c0a210400000000ff290400dc0500002b010004
Local IP: 10.108.234.238/24
Peer IP: 10.108.234.237
DNS1: 10.220.4.9
DNS2: 10.221.4.9
====
Connection is up (raw IP)


Can you advise something?


Offline Profile
PostPosted: Mon Dec 18, 2017 7:43 pm Reply with quote
Site AdminPosts: 6362Joined: Sat Nov 03, 2007 12:30 am
Have you disabled the "network notification" in the configuration?

There should be more lines in the "PPP Log" about the network being useable.


Offline Profile
PostPosted: Tue Dec 19, 2017 8:38 am Reply with quote
Posts: 3Joined: Mon Dec 18, 2017 4:05 pm
Hello Josh!
Everytime I see such "short" log. Network notfication option is enabled.
Attachment:
screenshot_20171211-173640.png
screenshot_20171211-173640.png [ 159.73 KiB | Viewed 518 times ]


Attachment:
screenshot_20171211-173627.png
screenshot_20171211-173627.png [ 151.88 KiB | Viewed 518 times ]



Offline Profile
PostPosted: Thu Dec 21, 2017 8:55 am Reply with quote
Posts: 3Joined: Mon Dec 18, 2017 4:05 pm
dear Josh!
I investigate and understand that there was no SuperSU installed (therre was "superuser" instead it). So as soon as I Installed TWRP and SuperSU - internet immediately appers (speed up to 2-3 MB)!
Attachment:
PN3H5ylbhUz9nncr9_WG47xgTeBbP858puESv7uNXow-.png
PN3H5ylbhUz9nncr9_WG47xgTeBbP858puESv7uNXow-.png [ 41.11 KiB | Viewed 526 times ]


Thank you very much for your very usefull widget!
Best regards!
Vladimir


Offline Profile
PostPosted: Fri Dec 22, 2017 7:18 pm Reply with quote
Site AdminPosts: 6362Joined: Sat Nov 03, 2007 12:30 am
Thank you for the report. This can help others with the same problem.

If you want you can contribute the missing Russian translation. I have attached the current Russian translation which is a bit outdated. New features were added since that time. I have inserted the English text for the new options.

If you are interested, read also this post or ask me if you need advice.
Attachments:
strings-ru.xml [12.04 KiB]
Downloaded 28 times

Offline Profile

Display posts from previous:  Sort by:

All times are UTC + 1 hour [ DST ]
Page 1 of 1
5 posts
Users browsing this forum: No registered users and 3 guests
Search for:
Post new topic  Reply to topic
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum