Automatic Activation, Hotplug and UDEV, Configuration
Post Reply
rsbthebest
Posts: 3
Joined: Sat Mar 29, 2014 2:31 pm

libusb.h missing error while installing usb_modeswitch !!!

Post by rsbthebest » Sat Mar 29, 2014 2:43 pm

Hello freinds i am first time here,

I was trying to install usb_modeswitch on

Linux Mint 16 64bit petra

But it sayed compilation error while running

Sudo make install

And error showed

Error while compiling #include<libusb.h>
Libusb.h not found.

What to do someone please help

Josh
Site Admin
Posts: 6533
Joined: Sat Nov 03, 2007 12:30 am

Re: libusb.h missing error while installing usb_modeswitch !

Post by Josh » Sat Mar 29, 2014 7:41 pm

First, you want to make sure there is no conflict with the "official" usb_modeswitch package.

Second, for compiling you need the libusb development package. See the README file in the source package, paragraph "How to install".

rsbthebest
Posts: 3
Joined: Sat Mar 29, 2014 2:31 pm

Re: libusb.h missing error while installing usb_modeswitch !

Post by rsbthebest » Mon Mar 31, 2014 5:33 am

Thanks for reply i dont really know any thing about conflict but i have installed all that was required including,

Libusb-dev
and some thing like
Tcl or tlc i cant remeber perfectly

But still error pleas help

Josh
Site Admin
Posts: 6533
Joined: Sat Nov 03, 2007 12:30 am

Re: libusb.h missing error while installing usb_modeswitch !

Post by Josh » Mon Mar 31, 2014 8:21 am

From the README:

"The main prerequisite for installing from source is the development package for
"libusb". It may be called "libusb-dev" or similar in your distribution. From
usb_modeswitch 2.0.0 it should have an "1.x" in the name to reflect the change
to libusb-1
."

You need to install "libusb1-dev" or similar (may also be "libusbx-dev").

rsbthebest
Posts: 3
Joined: Sat Mar 29, 2014 2:31 pm

Re: libusb.h missing error while installing usb_modeswitch !

Post by rsbthebest » Mon Mar 31, 2014 1:47 pm

OK i will try to find them too

v.fedyay
Posts: 2
Joined: Mon Apr 14, 2014 12:05 pm
Location: Kiev, Ukraine

Re: libusb.h missing error while installing usb_modeswitch !

Post by v.fedyay » Mon Apr 14, 2014 5:44 pm

I've met same problem today on my RaspberryPi with "Fedora remix release 18" installed.
libusb-devel package didn't work.
So I've found also libusbx package installed.
"Libusbx is a fork of the original libusb ... The libusbx fork was started by most of the libusb-1.0 developers, after the original libusb project did not produce a new release for over 18 month".

So, installing libusbx-devel package brought me needed for compilation source files.

Josh
Site Admin
Posts: 6533
Joined: Sat Nov 03, 2007 12:30 am

Re: libusb.h missing error while installing usb_modeswitch !

Post by Josh » Thu Apr 17, 2014 10:04 am

To elaborate further on the libusb1 / libusbx matter, I quote the following from libusbx.org:

"libusbx was a fork of libusb, a library that provides generic access to USB devices.
As of 2014.01.26, this project has been fully merged back into libusb and is being discontinued.
Since there will be no further releases of libusbx, you are strongly encouraged to switch to using libusb.
"

In conclusion, there may be both variants around in distributions for a while, until package updates will finally reflect the re-merge.

Post Reply