Author Message

<  Device Information  ~  ZTE MF190 (O2surfstick)

PostPosted: Wed Apr 06, 2011 8:33 am
Site AdminPosts: 4855Joined: Sat Nov 03, 2007 12:30 am
Excellent, thank you !

Will go into the next data package release.


Offline Profile
PostPosted: Sun Oct 16, 2011 7:54 pm
Posts: 2Joined: Sun Oct 16, 2011 7:30 pm
Hi Josh, I used these data to set up my modem and it works on ubuntu 11.04, but I still have many problems to the insistence that it wants connect to ttyUSB2, instead of -correct- ttyUSB4. The truth is that I found similar errors in modemmanager bugs in Ubuntu and I am gathering information on:

https://bugs.launchpad.net/ubuntu/+sour ... bug/875441

Best regards.


Offline Profile
PostPosted: Wed Oct 19, 2011 3:17 pm
Posts: 1Joined: Wed Oct 19, 2011 3:13 pm
my o2 surfstick practically works with the configuration for 19d2:0083, just usb_modeswitch doesn't recognize it was actually switched correctly.
i'd suggest this patch to fix that
Code:
--- a/usb_modeswitch.d/19d2:0083
+++ b/usb_modeswitch.d/19d2:0083
@@ -5,7 +5,7 @@ DefaultVendor= 0x19d2
 DefaultProduct=0x0083
 
 TargetVendor=  0x19d2
-TargetProduct= 0x0124
+TargetProductList="0117,0124"
 
 MessageContent="5553424312345678000000000000061b000000020000000000000000000000"
 


Offline Profile
PostPosted: Thu Oct 20, 2011 12:24 am
Posts: 2Joined: Sun Oct 16, 2011 7:30 pm
And 19d2:0124 variant no connect on Ubuntu 11.10

Hi, Today I tried installing ubuntu 11.10, and I failed to connect in any way. It's pretty disappointing because I do not like unity at all :D, and without a network connection it is difficult to shake it off. Also, under unity and unable to install my tools, is a bit difficult to do any debugging. One thing that struck me is that it always appears as 0x0124 and not 0x0149: does that no longer need to remove the cd in this version? (If so, it does not work very well: any suggestion to fix it? Edited: Tested and it's indifferent). For now I will continue with gnome 2 / ubuntu 11.4, where at least it works :).

Edited: Now I'm using wvdial and I don't have any problem.

Best regards.


Offline Profile

Display posts from previous:  Sort by:

All times are UTC + 1 hour [ DST ]
Page 2 of 2
19 posts
Go to page Previous  1, 2
Users browsing this forum: No registered users and 0 guests
Search for:
Post new topic  Reply to topic
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum