Author Message

<  Setup Discussion  ~  INQ Mini 3G - driver won't autoload

PostPosted: Wed Mar 10, 2010 3:54 pm
Posts: 4Joined: Wed Mar 10, 2010 3:24 pm
I'm using the INQ Mini 3G to connect online, here's how it shows up under lsusb

Code:
Bus 001 Device 005: ID 12d1:101e Huawei Technologies Co., Ltd.


Which is the same code as seen in this thread. It works, but the driver doesn't seem to load automatically, every time I reboot my machine or disconnect and reconnect the modem I have to go to terminal as root and type this in:-

Code:
# modprobe -v option
# echo "12d1 101e" > /sys/bus/usb-serial/drivers/option1/new_id


I've even tried depmod -a the last time I did this but I still need to type the command in next time.

When I plug the phone in it starts up in mass storage mode and changes over to modem mode after typing the echo command (which I know creates a file consisting of the phone's USB deivce ID in a config folder used by the driver) Thing is, how do I get this generated automatically or permanently?

I don't suppose it helps that this INQ handset has the same device ID as a Huawei handset yet the older INQ1 was manufactured by a different company (Amoi) and has a different USB device ID and I think uses a different driver.

I'm using MEPIS 8 which is based on Debian lenny/stable.[/url]


Offline Profile
PostPosted: Wed Mar 10, 2010 4:21 pm
Posts: 4Joined: Wed Mar 10, 2010 3:24 pm
Hmm, turns out I need both commands.

First command inserts the driver, second command tells the driver to mode switch the phone.

Disconnecting the phone means I have to manually remove the driver with rmmod option. If I disconnect and reconnect the phone, the phone reconnects in mass storage mode without the mode switch.

Also actually connecting to the internet is a bit hit and miss not sure if I need to reboot the phone to reconnect...


Offline Profile
PostPosted: Wed Mar 10, 2010 4:57 pm
Site AdminPosts: 4710Joined: Sat Nov 03, 2007 12:30 am
Which version of usb_modeswitch do you have installed?


Offline Profile
PostPosted: Wed Mar 10, 2010 6:17 pm
Posts: 4Joined: Wed Mar 10, 2010 3:24 pm
Version 0.9.7

and there's the problem, it's the version that came with the distro, hmm, I'm running 64-bit (amd64) linux. Hang on, I'll give the latest version a go...


Offline Profile
PostPosted: Wed Mar 10, 2010 6:55 pm
Posts: 4Joined: Wed Mar 10, 2010 3:24 pm
I think I've fixed it, took a while to realise that it's called usb_modeswitch with an underscore rather than a hyphen but I've got it sorted now, thanks!


Offline Profile
PostPosted: Wed Mar 10, 2010 7:39 pm
Site AdminPosts: 4710Joined: Sat Nov 03, 2007 12:30 am
Due to package name restrictions, underscores cannot be part of the name. So the recent 'official' packages and the tarball itself have the hyphen, but the component names managed to keep the underscore 8)

Automatic driver binding works reliably only since the latest release (1.1.0). Before 1.0.6 you have to do it manually anyway.


Offline Profile

Display posts from previous:  Sort by:

All times are UTC + 1 hour [ DST ]
Page 1 of 1
6 posts
Users browsing this forum: No registered users and 0 guests
Search for:
Post new topic  Reply to topic
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum