Author Message

<  Device Information  ~  not able to switch modem

PostPosted: Wed May 18, 2011 12:18 pm
Posts: 21Joined: Wed May 18, 2011 12:03 pm
here is my configuration:
Quote:
# Configuration for the usb_modeswitch package, a mode switching tool for
# USB devices providing multiple states or modes
#
# This file is evaluated by the wrapper script "usb_modeswitch_dispatcher"
# in /usr/sbin
# To enable an option, set it to "1", "yes" or "true" (case doesn't matter)
# Everything else counts as "disable"


# Disable automatic mode switching globally (e.g. to access the original
# install storage)

DisableSwitching=0


# Enable logging (results in a extensive report file in /var/log, named
# "usb_modeswitch_<interface-name>"

EnableLogging=0
########################################################
# MobiData MBD-200HU and others

DefaultVendor= 0x1c9e
DefaultProduct=0xf000

TargetVendor= 0x1c9e
TargetProduct= 0x9605

CheckSuccess=20

MessageContent="55534243123456788000000080000606f50402527000000000000000000000"


and here's the output:

Quote:

Looking for target devices ...
No devices in target mode or class found
Looking for default devices ...
Found devices in default mode or class (1)
Accessing device 005 on bus 001 ...
Using endpoints 0x01 (out) and 0x81 (in)
Using endpoints 0x01 (out) and 0x81 (in)
Inquiring device details; driver will be detached ...
Looking for active driver ...
No driver found. Either detached before or never attached


and here the process stops (does nothing)
can you guys suggest how to correct it?


Offline Profile
PostPosted: Wed May 18, 2011 12:37 pm
Posts: 21Joined: Wed May 18, 2011 12:03 pm
my modem is micromax mmx 310g


Offline Profile
PostPosted: Wed May 18, 2011 6:57 pm
Site AdminPosts: 4550Joined: Sat Nov 03, 2007 12:30 am
Please specify your environment in more detail:

Which usb_modeswitch version ? Data and program package installed ?

Which kernel version ? Which Linux distribution ?

Furthermore, please post the output of "dmesg" a little while after plugging the modem in, without any manual switching attempts.

Note: only the last 30-40 lines of "dmesg" text, please !!



Offline Profile
PostPosted: Wed May 18, 2011 8:08 pm
Posts: 21Joined: Wed May 18, 2011 12:03 pm
here is the dmesg result:
Quote:
[13669.212130] usb 1-2: new high speed USB device using ehci_hcd and address 9
[13669.357435] usb 1-2: New USB device found, idVendor=1c9e, idProduct=f000
[13669.357452] usb 1-2: New USB device strings: Mfr=3, Product=2, SerialNumber=4
[13669.357465] usb 1-2: Product: USB Modem
[13669.357474] usb 1-2: Manufacturer: USB Modem
[13669.357484] usb 1-2: SerialNumber: 000000000000
[13669.357784] usb 1-2: configuration #1 chosen from 1 choice
[13669.362030] scsi9 : SCSI emulation for USB Mass Storage devices
[13669.362340] usb-storage: device found at 9
[13669.362346] usb-storage: waiting for device to settle before scanning


i am using crunchbang linux (statler) with kernel 2.6.32-5-686.
the usb_modeswitch version is 201008


Offline Profile
PostPosted: Wed May 18, 2011 8:16 pm
Posts: 21Joined: Wed May 18, 2011 12:03 pm
hey! whatever i typed didn't display fully in my previous post. here's the full info:
usb_modeswitch version is : 20100826-1+squeeze0
but the same result was obtained by me when i used ubuntu with kernel 2.6.38-8 and the latest version of usb-modeswitch available in its repositories.
PS: what do you mean by data and program packages installed?


Offline Profile
PostPosted: Thu May 19, 2011 9:09 am
Site AdminPosts: 4550Joined: Sat Nov 03, 2007 12:30 am
There is no usb_modeswitch version 20100826. It may be the version of the data package. Regarding the two different packages, you might want to have a look at the main documentation page of usb_modeswitch (see link in the top nav bar).

Usually, distributions reflect those packages. So you have to install "usb-modeswitch" and "usb-modeswitch-data".

I have truncated your dmesg output, most of it is not of any interest. That's why I said: "the last 30-40 lines".



Offline Profile
PostPosted: Thu May 19, 2011 1:32 pm
Posts: 21Joined: Wed May 18, 2011 12:03 pm
ah! yes my fault. the usb_modeswitch version is 1.1.4-2


Offline Profile
PostPosted: Thu May 19, 2011 2:28 pm
Posts: 21Joined: Wed May 18, 2011 12:03 pm
btw, i forgot to mention that sakis3g works perfectly with my device. although takes a lot of time to switch the modem(approx. 30-40 seconds). well i wanted to automate the modem mode or somehow make it the default mode of the modem. i never use the usb storage device mode. can you suggest how can i permanently or automatically switch to modem mode.


Offline Profile
PostPosted: Thu May 19, 2011 8:12 pm
Site AdminPosts: 4550Joined: Sat Nov 03, 2007 12:30 am
The whole "framework" of usb_modeswitch is set up for the main purpose of making the switching process fully automatic. You need both packages, tcl and - most important - udev (which every desktop distribution should have).

Did I see that right that you put your device configuration into /etc/usb_modeswitch.conf ? This would be totally wrong.



Offline Profile
PostPosted: Fri May 20, 2011 8:51 am
Posts: 21Joined: Wed May 18, 2011 12:03 pm
yah i install the tcl package version 8.4.16-2 and i have the udev version164-3. and yes i put my configuration in /etc/usb_modeswitch.conf. what is wrong about it? i don't know how to set up udev rules or something like that. can you guide me step by step so that i can switch my modem to modem mode.


Offline Profile
PostPosted: Fri May 20, 2011 10:33 am
Posts: 21Joined: Wed May 18, 2011 12:03 pm
haha! just got a bit of success! i just installed the latest version of usb_modeswitch (1.1.7) and usb_modeswitch data. i made a few changes in the /lib/udev/rules.d/40-usb_modeswitch.rules file and /etc/usb_modeswitch.conf file. (i just removed the taget device list and specified one single target device id that is 0x9605. now when i start my computer with the device plugged in before booting, the lsusb command displays the device to be 1c9e:9605 which is what i want but when i plug in the device after the boot process the device remains 1c9e:f000 i.e. it doesn't switch automatically neither does it switch manually, the same problem i mentioned in the first post. please help me through this problem. i am just there!!! :) :) :)


Offline Profile
PostPosted: Fri May 20, 2011 11:15 am
Posts: 21Joined: Wed May 18, 2011 12:03 pm
now i have modified (the command of) sakis3g such that it connects to the internet automatically on double clicking it. now on one problem remains (the one i said earlier). the modem does not switch if i plug it in after booting but switches if i plug it in before booting. kindly suggest a method so that the device switches when i plug it after booting.
P.S.: I was also able to connect through gnome-ppp and wvdial (NM APPLET doesnt work) but Sakis3g connected the fastest (less than 10 sec.).


Offline Profile
PostPosted: Fri May 20, 2011 11:22 am
Posts: 21Joined: Wed May 18, 2011 12:03 pm
another bit of success. after i connect once using sakis3g, the nm applet also starts working (probably because sakis3g loads the option driver). but it takes more time to connect (15 sec.) yah i know there's not much difference but i'll be using sakis3g only. now please solve the problem i posted in the previous post. thanks in advance. :D :D :D


Offline Profile
PostPosted: Mon Jun 06, 2011 10:50 am
Posts: 21Joined: Wed May 18, 2011 12:03 pm
:? :? :? hey whenever i connect my usb modem through a usb hub (my monitor, dell p2211h has inbuilt usb hubs) my modem switches instantly but whenever i connect it directly to a usb-port on the back panel or the ones in my laptop the problem which i stated earlier exists. is there anyone who could tell me what is happening actually?


Offline Profile
PostPosted: Mon Jun 06, 2011 7:52 pm
Site AdminPosts: 4550Joined: Sat Nov 03, 2007 12:30 am
This is hard to say with the information you give. Did you enable usb_modeswitch logging? See the main doc page, paragraph "Troubleshooting" for details.


Offline Profile

Display posts from previous:  Sort by:

All times are UTC + 1 hour [ DST ]
Page 1 of 2
29 posts
Go to page 1, 2  Next
Users browsing this forum: No registered users and 0 guests
Search for:
Post new topic  Reply to topic
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum