Search found 6539 matches

by Josh
Sat Feb 01, 2020 10:05 pm
Forum: Device Information
Topic: Another e3372 newbie
Replies: 1
Views: 552

Re: Another e3372 newbie

There is never a hardware reset on these modems. Resetting amounts to unplugging and replugging. You can screw things up though with proprietary Huawei AT commands which can change modes permanently (stored in some flash memory). Maybe that's what you did with the DHCP server? Anyway, I think if the...
by Josh
Wed Jan 15, 2020 9:20 am
Forum: The PPP Widget Family for Android
Topic: Stuck on "setup modem"
Replies: 1
Views: 277

Re: Stuck on "setup modem"

That's unusual. There should be at least a sign of an attempt to talk to the modem in the PPP log. A few ideas: - Can it be an issue about insufficient power supply? - Is there any other system software that may try to use the modem? I suggest using a command shell access and trying to find out if t...
by Josh
Fri Jan 10, 2020 9:01 pm
Forum: Announcements
Topic: Forum Update
Replies: 0
Views: 1054

Forum Update

I have updated the forum software today.

If you stumble upon things that don't work, drop me a personal message. If that's not working either, be so kind and mail to usb_admin@draisberghof.de

Thanks!
by Josh
Mon Dec 16, 2019 9:31 am
Forum: Device Information
Topic: zte k3565z on Lubuntu 16.04.6
Replies: 31
Views: 1946

Re: zte k3565z on Lubuntu 16.04.6

Sorry, wrong typing. I entered it correctly, 19d2:2000' and i copied/pasted the text from the lenovo usb_modeswitch.conf file I will see the log again and come back with the content. There was a fundamental misunderstanding. DO NOT use the content of the global config file in a device config file ....
by Josh
Fri Dec 13, 2019 9:38 am
Forum: Device Information
Topic: zte k3565z on Lubuntu 16.04.6
Replies: 31
Views: 1946

Re: zte k3565z on Lubuntu 16.04.6

The file in /etc/usb_modeswitch.d must be named "19d2:2000" - colon, not "L".

If it still doesn't work, what does the log say after you plugged the modem in?
by Josh
Thu Nov 28, 2019 11:57 pm
Forum: Announcements
Topic: New data package release 20191128
Replies: 0
Views: 672

New data package release 20191128

Slight change of the 'skipping' rules to avoid unnecessary checks (thanks to Florian Zumbiehl) New devices: HP lt4220, Venus Fast2, D-Link DWA-171 Wifi Dongle, COMFAST CF-WU782AC WiFi Dongle, Vodafone/Huawei K5160, Vodafone/Huawei R218h (lkly compat. to E5573cs), Novatel USB730L, Novatel MiFi 6620L...
by Josh
Thu Nov 28, 2019 11:49 pm
Forum: Announcements
Topic: New release version 2.6.0
Replies: 0
Views: 595

New release version 2.6.0

New in 2.6.0: Removed included libjim source alltogether Rewrote parts of the dispatcher script to make location of global config file into a parameter: --config-file, so it can be customised now Replaced tcl helper file for jim embedding with a sh script, dropping the install dependency on a tcl in...
by Josh
Thu Nov 21, 2019 7:09 pm
Forum: The PPP Widget Family for Android
Topic: PPP Widget Via Bluetooth to Nokia Asha 503
Replies: 5
Views: 438

Re: PPP Widget Via Bluetooth to Nokia Asha 503

The problem is the PPP negotiation, the very last lines. I think the reply from PPP Widget to the request from the phone is not quite correct. Apart from that, it should work nicely. I have a Nokia 500 and I'm using it via Bluetooth.

I will look into it. May take a while though ...
by Josh
Thu Nov 21, 2019 9:09 am
Forum: Device Information
Topic: Please add Realtek (rtl) wifi dongle to usb_modeswitch-data
Replies: 1
Views: 429

Re: Please add Realtek (rtl) wifi dongle to usb_modeswitch-data

This forum is fine for such messages.

Will be included, thanks for the notification!
I'll get the actual configuration from the Fedora package.
by Josh
Thu Nov 21, 2019 9:07 am
Forum: Device Information
Topic: 1&1 XSstick W1208 (4g systems)
Replies: 15
Views: 3131

Re: 1&1 XSstick W1208 (4g systems)

I'm on it just now. Going slowly due to many other obligations but will be released in November.
by Josh
Mon Nov 11, 2019 6:35 pm
Forum: Device Information
Topic: Huawei E3531 with PI Zero W - USB Mass storage [SOLVED]
Replies: 8
Views: 4593

Re: Huawei E3531 with PI Zero W - USB Mass storage [SOLVED]

Same advice applies - don't use /etc/usb_modeswitch.conf for device configurations !! You likely have overwritten the original global configuration file with that name. Delete it, uninstall usb_modeswitch and re-install it. Then have a look at /etc/usb_modeswitch.conf again. If it exists, edit it an...
by Josh
Sun Nov 10, 2019 4:00 pm
Forum: Device Information
Topic: Usb_modeswitch-switch and CD, SD disable at one time !
Replies: 3
Views: 550

Re: Usb_modeswitch-switch and CD, SD disable at one time !

The "Reset" command is just passed through to "libusb". I didn't research much if it actually does anything.

If there is no symlink created then there is probably no serial port available.
What's the output of "lsusb -v -d 12d1:1505" (with the modem connected and switched)?
by Josh
Sun Nov 10, 2019 3:44 pm
Forum: Device Information
Topic: huawei e8372h-153 switching but not recognized as modem
Replies: 8
Views: 592

Re: huawei e8372h-153 switching but not recognized as modem

The Huawei modems E3272 and E3372 do not provide a PPP port anymore in the alternative mode, only a serial DIAG port and an NCM interface (optimized Ethernet flavour).
It's likely that newer ones follow that path.
by Josh
Sun Nov 10, 2019 3:39 pm
Forum: Device Information
Topic: zte k3565z on Lubuntu 16.04.6
Replies: 31
Views: 1946

Re: zte k3565z on Lubuntu 16.04.6

Without "StandardEject=1", the mode switch will likely not happen. Add it if it's missing.

You can simply copy the content of the Lenovo config into a file named "19d2:2000" in the folder "/etc/usb_modeswitch.d". That should do.
by Josh
Sun Nov 10, 2019 3:32 pm
Forum: Setup Discussion
Topic: Ubuntu only allows 1 active modem
Replies: 1
Views: 737

Re: Ubuntu only allows 1 active modem

The identical MAC address is likely the problem for the system. Try changing it for one modem. A quick search brought up this: https://forum.openwrt.org/t/huawei-4g-dongle-duplicate-mac-addresses/41214/6 It may also be a problem of Ubuntu not being able to combine the ports. I'm not familiar with it...