The C Source, Patches and (shudder!) Bugs
borbor
Posts: 2
Joined: Wed Nov 23, 2016 7:38 pm

Re: usb_modeswitch does not work with systemd 221

Post by borbor » Thu Nov 24, 2016 9:42 am

-rwxr-xr-x 1 root root 40568 Nov 17 04:39 /sbin/init

On UEFI system:

journalctl -b | grep init
Nov 24 08:34:06 localhost kernel: Kernel command line: root=/dev/sdd4 rootfstype=ext4 init=/usr/lib/systemd/systemd
Nov 24 08:34:06 localhost kernel: Memory: 16342392K/16694868K available (5447K kernel code, 813K rwdata, 1940K rodata, 1000K init, 588K bss, 352476K reserved, 0K cma-reserved)
Nov 24 08:34:06 localhost kernel: devtmpfs: initialized
.........

This (fresh) unstable gentoo was installed from
-rw-r--r-- 1 root root 249804534 Nov 19 15:30 stage3-amd64-20161117.tar.bz2 file.
I have also almost identical gentoo instalation (the same UEFI laptop,
Sep 19 08:28 stage3-amd64-20160915.tar.bz2), but
using openrc - here usb_modeswitch-2.4.0 works without any problems.
On openrc:
ls -l /mnt/mnt2/sbin/init
-rwxr-xr-x 1 root root 40568 Sep 15 05:38 /mnt/mnt2/sbin/init


On both systems there is no /etc/init directory
nor usb-modeswitch-upstart.conf file on the whole systems.

All files provided by usb-modeswitch:
/etc
/etc/usb_modeswitch.conf
/etc/usb_modeswitch.d
/lib
/lib/udev
/lib/udev/rules.d
/lib/udev/rules.d/40-usb_modeswitch.rules
/lib/udev/usb_modeswitch
/usr
/usr/lib
/usr/lib/systemd
/usr/lib/systemd/system
/usr/lib/systemd/system/usb_modeswitch@.service
/usr/sbin
/usr/sbin/usb_modeswitch
/usr/sbin/usb_modeswitch_dispatcher
/usr/share
/usr/share/doc
.....
/usr/share/man
/usr/share/man/man1
/usr/share/man/man1/usb_modeswitch.1.bz2
/usr/share/man/man1/usb_modeswitch_dispatcher.1.bz2
/usr/share/usb_modeswitch
/usr/share/usb_modeswitch/03f0:002a
.......
/var
/var/lib
/var/lib/usb_modeswitch

jkroon
Posts: 3
Joined: Wed Jan 04, 2017 1:31 pm

Re: usb_modeswitch does not work with systemd 221

Post by jkroon » Wed Jan 04, 2017 2:22 pm

Hi Josh,

I can't comment for the original op, but running Gentoo myself (kernel 4.8.3, sysvinit 2.88, udev 230 /sbin/init is a binary itself, not a symlink.

Code: Select all

jkroon@greyscale ~ $ ls -la /sbin/init 
-rwxr-xr-x 1 root root 40664 Oct 22 21:43 /sbin/init
jkroon@greyscale ~ $ equery belongs /sbin/init 
 * Searching for /sbin/init ... 
sys-apps/sysvinit-2.88-r9 (/sbin/init)
jkroon@greyscale ~ $ equery list udev
 * Searching for udev ...
[IP-] [  ] sys-fs/udev-230-r1:0
jkroon@greyscale ~ $ uname -a
Linux greyscale 4.8.3-uls #1 SMP PREEMPT Thu Oct 27 08:04:48 SAST 2016 x86_64 Intel(R) Core(TM) i7-3520M CPU @ 2.90GHz GenuineIntel GNU/Linux
jkroon@greyscale ~ $ 
Probably I'm somewhat "behind the times", but even with a /usr on a separate (unmounted by the time udev starts) my system works well. My only problem that I've got at the moment (at least that I'm aware of) is my modem doesn't switch on bootup ... and that's not a major problem for me.

Post Reply