Activation Codes and Methods, Hardware Details, Sniffing
aiamuzz
Posts: 46
Joined: Mon Jan 23, 2017 5:04 pm

Re: Novatel Expedite E371(Dell Wireless 5084)

Post by aiamuzz » Fri Jan 11, 2019 7:47 pm

nope ... on luck ...

Code: Select all

sudo ~/Downloads/qmi_setup.sh start
[sudo] password for muz: 
/home/muz/Downloads/qmi_setup.sh: line 44: /bin/ifconfig: No such file or directory
[11 Jan 2019, 23:04:39] -Warning ** Error reading from istream: Resource temporarily unavailable
error: couldn't create client for the 'dms' service: CID allocation failed in the CTL client: Transaction timed out
your wwan device may be RFKilled?
further the output for the command 'lsmod' ... shows the following

under ttyUSB0

Code: Select all

qmi_wwan               32768  0
cdc_wdm                20480  1 qmi_wwan
cdc_ether              16384  0
usbnet                 45056  2 cdc_ether,qmi_wwan
option                 53248  3
usb_wwan               20480  1 option
usbserial              45056  9 option,usb_wwan
under cdc-wdm

Code: Select all

qmi_wwan               32768  0
cdc_wdm                20480  2 qmi_wwan
cdc_ether              16384  0
usbnet                 45056  2 cdc_ether,qmi_wwan
option                 53248  3
usb_wwan               20480  1 option
usbserial              45056  8 option,usb_wwan
Can you spot anything wrong ... ?

aiamuzz
Posts: 46
Joined: Mon Jan 23, 2017 5:04 pm

Re: Novatel Expedite E371(Dell Wireless 5084)

Post by aiamuzz » Fri Jan 11, 2019 8:56 pm

Code: Select all

sudo ~/Downloads/qmi_setup.sh start
[sudo] password for muz: 
/home/muz/Downloads/qmi_setup.sh: line 44: /bin/ifconfig: No such file or directory
[11 Jan 2019, 23:04:39] -Warning ** Error reading from istream: Resource temporarily unavailable
error: couldn't create client for the 'dms' service: CID allocation failed in the CTL client: Transaction timed out
your wwan device may be RFKilled?

I did some changes in the below block in the file 'qmi_setup.sh'

WWAN_DEV=wwp0s26u1u5i6 - changed to the name as on my sytem
# your cdc_wdm modem location
CDC_WDM=/dev/cdc-wdm0
# this script uses following qmi commands
QMICLI=/usr/bin/qmicli
QMI_NETWORK=/usr/bin/qmi-network
# the places of following commands vary depending on your distribution
IFCONFIG=/sbin/ifconfig - changed from /bin to /sbin
DHCPCD=/sbin/dhcpcd - installed the package dhcpcd5 as this executable wasn't present
SUDO=/usr/bin/sudo


after the above modification to the setup file ... i am encountering this error ...

Code: Select all

sudo ~/Downloads/qmi_setup.sh start
[11 Jan 2019, 23:30:13] -Warning ** Error reading from istream: Resource temporarily unavailable
error: couldn't create client for the 'dms' service: CID allocation failed in the CTL client: Transaction timed out
your wwan device may be RFKilled?

Josh
Site Admin
Posts: 6534
Joined: Sat Nov 03, 2007 12:30 am

Re: Novatel Expedite E371(Dell Wireless 5084)

Post by Josh » Fri Jan 11, 2019 10:12 pm

It's possible that there is interference from the ModemManager or NetworkManager tool. I would try to disable it temporarily.

aiamuzz
Posts: 46
Joined: Mon Jan 23, 2017 5:04 pm

Re: Novatel Expedite E371(Dell Wireless 5084)

Post by aiamuzz » Sat Jan 12, 2019 7:10 am

seems here is a little progress ... but still no data connection ...

Code: Select all

sudo ~/Downloads/qmi_setup.sh start
[/dev/cdc-wdm0] Operating mode set successfully
Loading profile at /etc/qmi-network.conf...
    APN: bsnlnet
    APN user: unset
    APN password: unset
    qmi-proxy: no
Checking data format with 'qmicli -d /dev/cdc-wdm0 --wda-get-data-format '...
error: couldn't create client for the 'wda' service: QMI protocol error (31): 'InvalidServiceType'
Device link layer protocol not retrieved: WDA unsupported
Starting network with 'qmicli -d /dev/cdc-wdm0 --wds-start-network=apn='bsnlnet'  --client-no-release-cid '...
error: couldn't start network: QMI protocol error (14): 'CallFailed'
call end reason (1): generic-unspecified
verbose call end reason (2,204): [internal] unknown-cause
Saving state at /tmp/qmi-network-state-cdc-wdm0... (CID: 3)
error: network start failed, no packet data handle
Clearing state at /tmp/qmi-network-state-cdc-wdm0...
sending commands to master dhcpcd process

Code: Select all

 sudo ~/Downloads/qmi_setup.sh status
Loading profile at /etc/qmi-network.conf...
    APN: bsnlnet
    APN user: unset
    APN password: unset
    qmi-proxy: no
Getting status with 'qmicli -d /dev/cdc-wdm0 --wds-get-packet-service-status  '...


THE PROMPT WAS STUCK AT THIS POINT ... I HAD TO TERMINATE THE COMMAND.

Code: Select all

sudo ~/Downloads/qmi_setup.sh stop
[sudo] password for muz: 
Loading profile at /etc/qmi-network.conf...
    APN: bsnlnet
    APN user: unset
    APN password: unset
    qmi-proxy: no
Network already stopped
Clearing state at /tmp/qmi-network-state-cdc-wdm0...
cat: /var/run/dhcpcd-wwp0s26u1u5i6.pid: No such file or directory
kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill -l [sigspec]

aiamuzz
Posts: 46
Joined: Mon Jan 23, 2017 5:04 pm

Re: Novatel Expedite E371(Dell Wireless 5084)

Post by aiamuzz » Sat Jan 12, 2019 1:30 pm

please find additional logs after running the 'journalctl -f' command ...

i have attempted to connect immediately after login ...
WWAN_issue_journalctl -f_Log after reboot.txt
(68.62 KiB) Downloaded 34 times
hope this give you information on why i am facing this issue ... and hopefully leading to a solution to fix ...

thanks.

Josh
Site Admin
Posts: 6534
Joined: Sat Nov 03, 2007 12:30 am

Re: Novatel Expedite E371(Dell Wireless 5084)

Post by Josh » Sat Jan 12, 2019 9:41 pm

Looks like your only problem is this:

Code: Select all

couldn't start network: QMI protocol error (14): 'CallFailed'
Everything else seems to be working.

I'd say, either it's an issue with the connection data (APN?) or with your plan (rather: limitations of it).

aiamuzz
Posts: 46
Joined: Mon Jan 23, 2017 5:04 pm

Re: Novatel Expedite E371(Dell Wireless 5084)

Post by aiamuzz » Sat Jan 12, 2019 10:28 pm

Josh wrote:Looks like your only problem is this:

Code: Select all

couldn't start network: QMI protocol error (14): 'CallFailed'
Everything else seems to be working.

I'd say, either it's an issue with the connection data (APN?) or with your plan (rather: limitations of it).
this is the problem only when the port is loaded as 'cdc_wdm0' ... but when it is loaded as 'ttyUSB0' the same apn and plan works ... its working currently out of a different and older version of the same OS installation.


under 'cdc_wdm0'

Code: Select all

cdc_wdm                20480  2 qmi_wwan
usbserial              45056  8 option,usb_wwan
under 'ttyUSB0'

Code: Select all

cdc_wdm                20480  1 qmi_wwan
usbserial              45056  9 option,usb_wwan
notice the instances('used by' count) of 'cdc_wdm' and 'usbserial' turn from 1 to 2 and 9 to 8 respectively ?
need to figure out what is that device/process that's dropping an instance of 'usbserial' and starting an additional instance of cdc_wdm module

seems like for a successful data connection ... a single instance of the cdc_wdm is what seems to work ... when 2 instances are running it somehow fails to connect data !!!

forgive the terms / phrases i may be using ... just been researching on this issue and trying to wrap my head around the concept of kernel modules ...

Post Reply