Activation Codes and Methods, Hardware Details, Sniffing
Makinen
Posts: 21
Joined: Thu May 16, 2019 12:56 am

Re: zte k3565z on Lubuntu 16.04.6

Post by Makinen » Tue Dec 17, 2019 1:04 am

Sorry Josh, i' m not so advanced. I will try to find the device conf file and come back here

Makinen
Posts: 21
Joined: Thu May 16, 2019 12:56 am

Re: zte k3565z on Lubuntu 16.04.6

Post by Makinen » Wed Dec 18, 2019 9:13 pm

Unfortunately no success, i will resume as following.

Around 3 months ago i downloaded from lubuntu site and install a lubuntu version 16.04.6 on a usb drive. This is exatcly the same as
the updated version on April 2019 installed on dell, with kernel 4.15.0-45
The result was the same and the modem doesn't work in both dell and lenovo. But it works with the 16.04.6 version on lenovo pinned
at kernel 4.8.0-46. I use this usb drive for testing only.

Now, i did what you suggested but with no success.
I found the device file in the /usr/shate/usb_modeswitch/configPack.tar.gz

Surprisingly the content is the same in the 'defected; 16.04.6 /kernel 4.15.version.
I mean that it says exactly what you send me.
which is the following with the #_ZTE devices on the top.

"# ZTE devices
TargetVendor= 0x19d2
TargetProductList="0001,0002,0015,0016,0017,0019,0031,0033,0037,0042,0052,0055,0061,0063,0064,0066,0091,0108,0117,0128,0151,0157,0177,1402,2002,2003"
StandardEject=1
MessageContent="55534243123456702000000080000c85010101180101010101000000000000"

and the last log output is the following:


"USB_ModeSwitch log from Wed Dec 18 19:07:18 2019

Use global config file: /etc/usb_modeswitch.conf


Started via systemd
Raw args from udev: 2-1

Bus ID for device not given by udev.
Trying to determine it from kernel name (2-1) ...
Use top device dir /sys/bus/usb/devices/2-1

USB dir exists: /sys/bus/usb/devices/2-1

SCSI dir exists: /sys/bus/usb/devices/2-1
Warning: SCSI attribute "vendor" not readable.
Warning: SCSI attribute "model" not readable.
Warning: SCSI attribute "rev" not readable.
Use interface /sys/bus/usb/devices/2-1/2-1:1.0
----------------
USB values from sysfs:
idVendor 19d2
idProduct 2000
manufacturer ZTE,Incorporated
product ZTE CDMA Technologies MSM
serial P673A2VDF_MS
bNumConfigurations 1
bConfigurationValue 1
devnum 5
busnum 2
----------------
bNumConfigurations is 1 - don't check for active configuration
Found packed config collection /usr/share/usb_modeswitch/configPack.tar.gz
Searching entries named: /usr/share/usb_modeswitch/19d2:2000*
Searching overriding entries named: /etc/usb_modeswitch.d/19d2:2000*
SCSI attributes not needed, move on.

Use overriden config 19d2:2000 from collection /etc/usb_modeswitch.d
config: TargetVendor set to 19d2
config: TargetProduct set to 0001,0002,0015,0016,0017,0019,0031,0033,0037,0042,0052,0055,0061,0063,0064,0066,0091,0108,0117,0128,0151,0157,0177,1402,2002,2003
Driver module is "option", ID path is /sys/bus/usb-serial/drivers/option1
! matched, now switching
Unbinding driver
Command to be run:
/usr/sbin/usb_modeswitch -W -D -s 20 -c /etc/usb_modeswitch.d/19d2:2000 -u -1 -b 2 -g 5 -v 19d2 -p 2000 2>&1

Verbose debug output of usb_modeswitch and libusb follows
(Note that some USB errors are expected in the process)
--------------------------------

Read config file: /etc/usb_modeswitch.d/19d2:2000

* usb_modeswitch: handle USB devices with multiple modes
* Version 2.2.5 (C) Josua Dietze 2015
* Based on libusb1/libusbx

! PLEASE REPORT NEW CONFIGURATIONS !

DefaultVendor= 0x19d2
DefaultProduct= 0x2000
TargetVendor= 0x19d2
TargetProductList="0001,0002,0015,0016,0017,0019,0031,0033,0037,0042,0052,0055,0061,0063,0064,0066,0091,0108,0117,0128,0151,0157,0177,1402,2002,2003"
MessageContent="55534243123456702000000080000c85010101180101010101000000000000"
NeedResponse=0
Success check enabled, max. wait time 20 seconds
System integration mode enabled

Use given bus/device number: 002/005 ...
Look for default devices ...
bus/device number matched
found USB ID 19d2:2000
vendor ID matched
product ID matched
Found devices in default mode (1)
Use interface number 0
Use endpoints 0x01 (out) and 0x81 (in)

USB description data (for identification)
-------------------------
Manufacturer: ZTE,Incorporated
Product: ZTE CDMA Technologies MSM
Serial No.: P673A2VDF_MS
-------------------------
Looking for active driver ...
OK, driver detached
Set up interface 0
Use endpoint 0x01 for message sending ...
Trying to send message 1 to endpoint 0x01 ...
OK, message successfully sent
Reset response endpoint 0x81
Reset message endpoint 0x01
ok:busdev
--------------------------------
(end of usb_modeswitch output)
Check success of mode switch for max. 20 seconds ... Read attributes ...
USB dir exists: /sys/bus/usb/devices/2-1
idProduct doesn't match the expected value. ('0001,0002,0015,0016,0017,0019,0031,0033,0037,0042,0052,0055,0061,0063,0064,0066,0091,0108,0117,0128,0151,0157,0177,1402,2002,2003' != '2000')
Attributes are different but target values are unexpected: idVendor: 19d2
idProduct: 2000
manufacturer: ZTE,Incorporated
product: ZTE CDMA Technologies MSM
serial: P673A2VDF_MS
bNumConfigurations: 1
bConfigurationValue: 1
devnum: 5
busnum: 2
Mode switching was successful, found 19d2:2000 (ZTE,Incorporated: ZTE CDMA Technologies MSM)Now check for bound driver ...
no driver has bound to interface 0 yet
Device not in "bind_list" yet, bind it now
Module loader is /sbin/modprobe
Module is active already
Try to add ID to driver "option"
ID added to driver; check for new devices in /dev
driver binding failed
Check for AVOID_RESET_QUIRK kernel attribute
AVOID_RESET_QUIRK activated

All done, exit

Comments.
1. If the device.conf is ok and StandatdEject=1 why doesn't work and log give wrong output?
2. i noticed that wvdial says that modem is not detected, and may be used by another program
3. Is it possible an issue with the network manager ?
Finally i don't want to bother you but if ok we can do some other testing, although i' m not an experienced user.

Post Reply