Page 1 of 3

zte k3565z on Lubuntu 16.04.6

Posted: Thu May 16, 2019 12:11 pm
by Makinen
After updating Lubuntu 16.04.6 to kernel 4.15.0-48 on a dell laptop, 3g usb modem zte k3565z model is detected as different zte model (mf627/628-636).
This modem (k3565z)was working perfectly even on 18.04 version(out of the box) for years, until i updated kernel.
I tried boot with the previous kernel 4.15.0.43 but didn’t work either.

I used a friend’s lenovo laptop where the modem is detected properly with the correct qmi_wwan drivers attached. Comparison is as follows distinguished as dell - lenovo.:

Wrong on Dell

~lsusb
Bus 002 Device 004: ID 19d2:2000 ZTE WCDMA Technologies MSM MF627/
MF628/MF628+/MF636+ HSDPA/HSUPA
~usb-devices
T: Bus=02 Lev=01 Prnt=01 Port=02 Cnt=01 Dev#= 4 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=19d2 ProdID=2000 Rev=00.00
S: Manufacturer=ZTE,Incorporated
S: Product=ZTE CDMA Technologies MSM
S: SerialNumber=P673A2VDF_MS
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)


Correct on Lenovo

~lsusb
Bus 002 Device 005: ID 19d2:0063 ZTE WCDMA Technologies MSM K3565-Z HSDPA

~usb-devices
T: Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 5 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=19d2 ProdID=0063 Rev=00.00
S: Manufacturer=ZTE,Incorporated
S: Product=ZTE CDMA Technologies MSM
C: #Ifs= 6 Cfg#= 1 Atr=e0 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
I: If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
I: If#= 3 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
I: If#= 4 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=qmi_wwan
I: If#= 5 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage

May new kernel doesn’t support old usb modems?
What are the option i have here ? because i m a 3 years new user
Change the device name correctly and how?
Remove last update to check if it works properly ?
Is using scanModem will help?

Re: zte k3565z on Lubuntu 16.04.6

Posted: Thu May 16, 2019 3:39 pm
by LOM
Makinen wrote: Wrong on Dell

~lsusb
Bus 002 Device 004: ID 19d2:2000 ZTE WCDMA Technologies MSM MF627/
MF628/MF628+/MF636+ HSDPA/HSUPA
~usb-devices
T: Bus=02 Lev=01 Prnt=01 Port=02 Cnt=01 Dev#= 4 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=19d2 ProdID=2000 Rev=00.00
S: Manufacturer=ZTE,Incorporated
S: Product=ZTE CDMA Technologies MSM
S: SerialNumber=P673A2VDF_MS
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)

The above is the initial configuration (virtual cd-rom with windows drivers and windows connection manager)
it has not been mode switched at this point.
Make sure that usb_modeswitch is installed in your Lubuntu distro and is up to date.

Re: zte k3565z on Lubuntu 16.04.6

Posted: Fri May 17, 2019 12:23 pm
by Makinen
Usb modeswitch is installed version 2.2.5 (C)

Re: zte k3565z on Lubuntu 16.04.6

Posted: Fri May 17, 2019 12:48 pm
by LOM
Makinen wrote:After updating Lubuntu 16.04.6 to kernel 4.15.0-48 on a dell laptop, 3g usb modem zte k3565z model is detected as different zte model (mf627/628-636).
This modem (k3565z)was working perfectly even on 18.04 version(out of the box) for years, until i updated kernel.
I tried boot with the previous kernel 4.15.0.43 but didn’t work either.
Lubuntu 16.04.6 was released 3 month ago and the distro maintainers has decided to include a 4 year old usb_modeswitch version. :cry:
There has been 6 update releases of usb_modeswitch since version 2.2.5.

Sorry but your problem is not a problem with usb_modeswitch in itself but a problem of how it has been included in your lubuntu distro. You'll have to file a bug report with the lubuntu maintainers.

Re: zte k3565z on Lubuntu 16.04.6

Posted: Fri May 17, 2019 12:53 pm
by Makinen
Also there is a difference between the two machines modem manager starus lenovo and dell as follows

Re: zte k3565z on Lubuntu 16.04.6

Posted: Fri May 17, 2019 1:04 pm
by Makinen
Oww, seems difficult. If you can help how can i file a bug, is this https://codingnest.com/how-to-file-a-good-bug-report/ a good guide ?
and where find lubuntu maintainers, searching?

Re: zte k3565z on Lubuntu 16.04.6

Posted: Sun May 19, 2019 12:27 pm
by LOM
Makinen wrote:Oww, seems difficult. If you can help how can i file a bug, is this https://codingnest.com/how-to-file-a-good-bug-report/ a good guide ?
and where find lubuntu maintainers, searching?
I have no idea, to find that out I would have to google and you should be able to do that yourself.

Re: zte k3565z on Lubuntu 16.04.6

Posted: Mon May 20, 2019 11:04 am
by Makinen
Thank you

Re: zte k3565z on Lubuntu 16.04.6

Posted: Mon May 27, 2019 8:31 pm
by Josh
Have you checked usb_modeswitch's log?

Enable logging in /etc/usb_modeswitch.conf and connect the modem again.

Re: zte k3565z on Lubuntu 16.04.6

Posted: Tue May 28, 2019 8:02 pm
by Makinen
Ok, i will try and will report here.

Re: zte k3565z on Lubuntu 16.04.6

Posted: Tue May 28, 2019 8:29 pm
by Makinen
With this command, sudo /etc/usb_modeswitch.conf
the output is as follows.

[image deleted, please use text copy and paste]

Re: zte k3565z on Lubuntu 16.04.6

Posted: Wed May 29, 2019 6:42 pm
by Josh
That's a misunderstanding - you need to open the file /etc/usb_modeswitch.conf with an editor.

It should tell you what to do to enable logging and where to find the log.

Re: zte k3565z on Lubuntu 16.04.6

Posted: Wed May 29, 2019 7:45 pm
by Makinen
The command i entered is: sudo /etc/usb_modeswitch.conf
and output isL command not found

Re: zte k3565z on Lubuntu 16.04.6

Posted: Wed May 29, 2019 7:48 pm
by Makinen
Ok, now opened the file with : leafpad /etc/usb_modeswitch.conf

I 'll see what i can do and come back here
Thank you

Re: zte k3565z on Lubuntu 16.04.6

Posted: Thu May 30, 2019 11:09 am
by Makinen
This is the content of the file usb_modeswitch
I will change to value EnableLogging=1



# Configuration for the usb_modeswitch package, a mode switching tool for
# USB devices providing multiple states or modes
#
# Evaluated by the wrapper script /usr/sbin/usb_modeswitch_dispatcher
#
# To enable an option, set it to "1", "yes" or "true" (case doesn't matter)
# Everything else counts as "disable"


# Disable automatic mode switching globally (e.g. to access the original
# install storage)

DisableSwitching=0

# Disable check for MBIM module presence and configuration globally (to aid
# special embedded environments)

DisableMBIMGlobal=0

# Enable logging (results in a extensive report file in /var/log, named
# "usb_modeswitch_<interface-name>" and probably others

EnableLogging=0


# Optional increase of "delay_use" for the usb-storage driver; there are hints
# that a recent kernel default change to 1 sec. may lead to problems, particu-
# larly with USB 3.0 ports. Set this to at least 3 (seconds) in that case.
# Does nothing if the current system value is same or higher

#SetStorageDelay=4