Activation Codes and Methods, Hardware Details, Sniffing
Post Reply
accessramesh
Posts: 3
Joined: Mon Aug 12, 2019 2:16 pm

Digisol (BG-BA4305) 4G LTE USB Dongle not supported

Post by accessramesh » Mon Aug 12, 2019 2:54 pm

Hi All,

I am trying to make Digisol 4G dongle (BG-BA4305) to work in my Openwrt box. But, found that the default VID/PID (0x2020/0x2030) isn't supported in the usb-mode.json. I searched online & found that it's actually a BroadMobi BM806U chipset based on Qualcomm MDM9225.

In Openwrt, I edited the .json & tried the standard eject & some of the other entries in the usb-mode.json file. But, nothing got it to switch from Disk to modem mode.

My Standard eject command:
{
"messages" : [ ],
"devices" : {
"2020:2030": {
"*": {
"t_vendor": 8224,
"t_product": [ 8243 ],
"mode": "StandardEject",
"msg": [ ],
"wait": 2
}
}
}
}
When I plug the dongle in a Ubuntu machine - it works fine.

Device comes up with VID/PID = 0x2020/2030 (SCSI disk mode) first
UDEV rules call eject on the SCSI device
Device switches mode & comes up in modem mode with VID/PID = (0x2020/0x2033)

Any help on the same is highly appreciated.

Thanks,
Ramesh

LOM
Posts: 1286
Joined: Wed Jul 11, 2012 3:14 pm
Location: Koh Samui, TH

Re: Digisol (BG-BA4305) 4G LTE USB Dongle not supported

Post by LOM » Mon Aug 12, 2019 4:10 pm

2020:2030 is the initial id for a bunch of BroadMobi oem devices (2020:2031, 2020:2032, 2020:2033 ....) and the switching is done with the StandardEject message which equals a cmdline eject of the virtual cd-rom (as you learned from Ubuntu). One of these oem devices is Ollicard 600 which was reported here a few month ago so 2020:2030 will be included in usb_modeswitch in the future.

I can't tell why it doesn't work in OpenWRT but they have their own switching tool (usbmode, usbmode.json which isn't the original usb_modeswitch. You'll have to ask in their forum for support of their switch tool.

accessramesh
Posts: 3
Joined: Mon Aug 12, 2019 2:16 pm

Re: Digisol (BG-BA4305) 4G LTE USB Dongle not supported

Post by accessramesh » Mon Aug 12, 2019 4:35 pm

Thanks for the quick revert @LOM. I did try usb_modeswitch (--std-eject) on Ubuntu 16.04 Desktop. Still it didn't switch.. Am I missing something?

# usb_modeswitch -W -v 0x2020 -p 0x2030 -V 0x2020 -P 0x2033 -K

Thanks,
Ramesh

LOM
Posts: 1286
Joined: Wed Jul 11, 2012 3:14 pm
Location: Koh Samui, TH

Re: Digisol (BG-BA4305) 4G LTE USB Dongle not supported

Post by LOM » Mon Aug 12, 2019 5:41 pm

accessramesh wrote:I did try usb_modeswitch (--std-eject) on Ubuntu 16.04 Desktop. Still it didn't switch.. Am I missing something?

# usb_modeswitch -W -v 0x2020 -p 0x2030 -V 0x2020 -P 0x2033 -K

Thanks,
Ramesh
Ubuntu 16.04 is quite old and they are usually far behind on usb_modeswitch version..
Which usb_modeswitch version was used?
I suspect that either StandardEject was not supported in that version or that StandardEject only
supported switching on SCSI LUN 0 while the virtual cd-rom may be on LUN 1.
Latest version of usb_modeswitch will send eject message to both LUN 0 and LUN1 when using StandardEject.

Your dmesg will show the SCSI LUN when the virtual cd-rom is probed.

accessramesh
Posts: 3
Joined: Mon Aug 12, 2019 2:16 pm

Re: Digisol (BG-BA4305) 4G LTE USB Dongle not supported

Post by accessramesh » Mon Aug 19, 2019 8:20 am

Thanks @LOM. The device was indeed in SCSI LUN 1. After upgrading usb_modeswitch, StdEject did the job.

Thanks,
Ramesh

Post Reply