Automatic Activation, Hotplug and UDEV, Configuration
Post Reply
freibadschwimmer
Posts: 2
Joined: 13 Oct 2015, 22:56

Huawei E3372 12d1:157d not switching

Post by freibadschwimmer » 13 Oct 2015, 23:27

Since the other threads regarding that modem did not reflect my problem I start a new here:

I am trying to get my E3372 working, however I do not succeed switching to modem mode.
When plugged in the cyan light is on, and network manager shows that the modem would be connected, though I cannot send/recieve data.

Software installed is:
usb-modeswitch: 2.2.5+repack0-1
usb-modeswitch-data: 20150627-1
Kernel 3.16 ( Debian 8 )

I can find the modem in the ConfigPack:
tar zxOvf /usr/share/usb_modeswitch/configPack.tar.gz 12d1:157d
# Huawei E3331, E3372
TargetVendor=0x12d1
TargetProductList="14db,14dc"
HuaweiNewMode=1
Since it does not switch automatically, I tried to do it manually, first:
sudo usb_modeswitch -H -v 0x12d1 -p 0x157d
I get:
Look for default devices ...
product ID matched
Found devices in default mode (1)
Access device 010 on bus 005
Current configuration number is 2
Use interface number 0

USB description data (for identification)
-------------------------
Manufacturer: HUAWEI_MOBILE
Product: HUAWEI_MOBILE
Serial No.: 0123456789ABCDEF
-------------------------
Send old Huawei control message ...
-> Run lsusb to note any changes. Bye!
but it doesn't change, lsusb still shows me 12d1:157d

and when I try:
sudo usb_modeswitch -J -v 0x12d1 -p 0x157d

I get:
Look for default devices ...
product ID matched
Found devices in default mode (1)
Access device 010 on bus 005
Current configuration number is 2
Use interface number 0
Error: message endpoint not given or found. Abort
Unfortunately I don't understand that error message;
Anyone an idea how to get the modem working?
Thanks!

LOM
Posts: 1350
Joined: 11 Jul 2012, 15:14
Location: Koh Samui, TH

Re: Huawei E3372 12d1:157d not switching

Post by LOM » 14 Oct 2015, 04:37

12d1:157d will not be switched to a new id if your system contains the cdc_mbim driver, it will remain with its initial id but usb_modeswitch will select its config 2 which is an mbim configuration.
You can see from your logs that this has happened so NetworkManager (if not too old) should now be able to pick up the wwan ethernet device created by the cdc_mbim driver.

usb_modeswitch will switch the device into 12d1:14db/14dc if the cdc_mbim driver is absent or if the usb_modeswitch.conf file contains the line "DisableMBIMGlobal=1"

freibadschwimmer
Posts: 2
Joined: 13 Oct 2015, 22:56

Re: Huawei E3372 12d1:157d not switching

Post by freibadschwimmer » 14 Oct 2015, 10:45

Thank you very much for your response and help!

I have to admit that your answer gives me some more reading as I don't really understand yet what the cdc_mbim driver or mbim is or does.

Anyhow, in the file /etc/usb_modeswitch.conf I set
DisableMBIMGlobal=1

and now the modem is working fine (in HiLink mode); I can access now also the modem's settings in the browser by pointing it to http://192.168.8.1

Thanks for your input!

Cheers!

adojaan
Posts: 2
Joined: 14 Nov 2015, 20:33

Re: Huawei E3372 12d1:157d not switching

Post by adojaan » 14 Nov 2015, 20:36

I spent hours to get e3372 (in hi-link mode) working on Raspbian, seemed that usb_modeswitch simply does not change the mode whatever I tried. The solution was to connect the USB modem to external powered USB hub, not directly to Rpi.

nbg12
Posts: 3
Joined: 28 Aug 2018, 08:29

Re: Huawei E3372 12d1:157d not switching

Post by nbg12 » 28 Aug 2018, 15:28

freibadschwimmer wrote:Thank you very much for your response and help!

I have to admit that your answer gives me some more reading as I don't really understand yet what the cdc_mbim driver or mbim is or does.

Anyhow, in the file /etc/usb_modeswitch.conf I set
DisableMBIMGlobal=1

and now the modem is working fine (in HiLink mode); I can access now also the modem's settings in the browser by pointing it to http://192.168.8.1

Thanks for your input!

Cheers!


!!! WOW !!!


to change DisableMBIMGlobal=1 was the BIG THINGGG!

THXXXXX

Post Reply