Automatic Activation, Hotplug and UDEV, Configuration
Post Reply
unoc_u34
Posts: 5
Joined: 27 Jul 2018, 09:35

HSUPA Qualcomm CDMA Tech MSM USB-modem don't change the mode

Post by unoc_u34 » 27 Jul 2018, 09:49

Hi guys! First sorry for my English! I plugged USB-modem, made in Chine, model HSUPA A1

Code: Select all

Bus 002 Device 004: ID 05c6:f000 Qualcomm, Inc. 

Code: Select all

[root@svri6896ve userj]# lsusb -v -d 05c6:f000

Bus 002 Device 004: ID 05c6:f000 Qualcomm, Inc. 
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  idVendor           0x05c6 Qualcomm, Inc.
  idProduct          0xf000 
  bcdDevice            0.00
  iManufacturer           3 Qualcomm, Incorporated
  iProduct                2 Qualcomm CDMA Technologies MSM
  iSerial                 4 861179030861223
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           32
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          1 Qualcomm Configuration
    bmAttributes         0xc0
      Self Powered
    MaxPower              500mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass         8 Mass Storage
      bInterfaceSubClass      6 SCSI
      bInterfaceProtocol     80 Bulk-Only
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
Device Qualifier (for other device speed):
  bLength                10
  bDescriptorType         6
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  bNumConfigurations      1
Device Status:     0x0000
  (Bus Powered)
I want chenge mode on USB modem and use this command:

Code: Select all

usb_modeswitch -v 0x05c6 -p 0xf000 -V 0x05c6 -P 0x9000 -m 0x01 -M "5553424312345678000000000000061b000000020000000000000000000000"
But after command PID don't change to => 9000

Code: Select all

[root@svri6896ve userj]# usb_modeswitch -v 0x05c6 -p 0xf000 -V 0x05c6 -P 0x9000 -m 0x01 -M "5553424312345678000000000000061b000000020000000000000000000000"
Look for target devices ...
 No devices in target mode or class found
Look for default devices ...
 Found devices in default mode (1)
Access device 004 on bus 002
Get the current device configuration ...
Current configuration number is 1
Use interface number 0
 with class 8
Use endpoints 0x01 (out) and 0x81 (in)
Looking for active drivers ...
Set up interface 0
Use endpoint 0x01 for message sending ...
Trying to send message 1 to endpoint 0x01 ...
 OK, message successfully sent
Read the response to message 1 (CSW) ...
 Response successfully read (13 bytes), status 1
Reset response endpoint 0x81
Reset message endpoint 0x01
-> Run lsusb to note any changes. Bye!

Code: Select all

[root@svri6896ve userj]# lsusb
Bus 002 Device 004: ID 05c6:f000 Qualcomm, Inc. 
Bus 002 Device 006: ID 12d1:1001 Huawei Technologies Co., Ltd. E161/E169/E620/E800 HSDPA Modem
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0557:2221 ATEN International Co., Ltd Winbond Hermon
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Please help me guys. Thank in advance

Josh
Site Admin
Posts: 6569
Joined: 03 Nov 2007, 00:30

Re: HSUPA Qualcomm CDMA Tech MSM USB-modem don't change the mode

Post by Josh » 27 Jul 2018, 17:29

Try the "standard eject" parameter, leave out all those other parameters:

Code: Select all

# usb_modeswitch -v 0x05c6 -p 0xf000 -K

unoc_u34
Posts: 5
Joined: 27 Jul 2018, 09:35

Re: HSUPA Qualcomm CDMA Tech MSM USB-modem don't change the mode

Post by unoc_u34 » 27 Jul 2018, 18:11

Josh wrote:Try the "standard eject" parameter, leave out all those other parameters:

Code: Select all

# usb_modeswitch -v 0x05c6 -p 0xf000 -K
Thamn for you for reply!
Command result:

Code: Select all

[root@svri6896ve userj]# usb_modeswitch -v 0x05c6 -p 0xf000 -K
Look for default devices ...
 Found devices in default mode (1)
Access device 004 on bus 002
Get the current device configuration ...
Current configuration number is 1
Use interface number 0
 with class 8
Use endpoints 0x01 (out) and 0x81 (in)
Sending standard EJECT sequence
Looking for active drivers ...
Set up interface 0
Use endpoint 0x01 for message sending ...
Trying to send message 1 to endpoint 0x01 ...
 OK, message successfully sent
Read the response to message 1 (CSW) ...
 Response successfully read (13 bytes), status 0
Trying to send message 2 to endpoint 0x01 ...
 OK, message successfully sent
Read the response to message 2 (CSW) ...
 Response successfully read (13 bytes), status 0
Trying to send message 3 to endpoint 0x01 ...
 OK, message successfully sent
Read the response to message 3 (CSW) ...
 Response successfully read (13 bytes), status 1
Trying to send message 4 to endpoint 0x01 ...
 Sending the message returned error -1. Try to continue
Read the response to message 4 (CSW) ...
 Response reading failed (error -1)
 Device is gone, skip any further commands
-> Run lsusb to note any changes. Bye!

Code: Select all

[root@svri6896ve userj]# lsusb
Bus 002 Device 007: ID 05c6:6000 Qualcomm, Inc. Siemens SG75

Code: Select all

[root@svri6896ve userj]# ls /dev
autofs           fd         log                 ptmx    sda6    shm       tty15  tty28  tty40  tty53  tty9     usbmon2  vcsa6
block            full       loop-control        ptp0    sdb     snapshot  tty16  tty29  tty41  tty54  ttyS0    vcs      vfio
bsg              fuse       mapper              ptp1    serial  snd       tty17  tty3   tty42  tty55  ttyS1    vcs1     vga_arbiter
btrfs-control    hidraw0    mcelog              pts     sg0     stderr    tty18  tty30  tty43  tty56  ttyS2    vcs2     vhci
bus              hidraw1    mem                 random  sg1     stdin     tty19  tty31  tty44  tty57  ttyS3    vcs3     vhost-net
char             hpet       memory_bandwidth    raw     sg10    stdout    tty2   tty32  tty45  tty58  [b]ttyUSB0[/b]  vcs4     vhost-vsock
console          hugepages  mqueue              rtc     sg2     tty       tty20  tty33  tty46  tty59  [b]ttyUSB1[/b]  vcs5     watchdog
core             hwrng      net                 rtc0    sg3     tty0      tty21  tty34  tty47  tty6   [b]ttyUSB2[/b]  vcs6     watchdog0
cpu              initctl    network_latency     sda     sg4     tty1      tty22  tty35  tty48  tty60  [b]ttyUSB3[/b]  vcsa     zero
cpu_dma_latency  input      network_throughput  sda1    sg5     tty10     tty23  tty36  tty49  tty61  uhid     vcsa1
cuse             ipmi0      null                sda2    sg6     tty11     tty24  tty37  tty5   tty62  uinput   vcsa2
disk             kmsg       nvram               sda3    sg7     tty12     tty25  tty38  tty50  tty63  urandom  vcsa3
dri              kvm        port                sda4    sg8     tty13     tty26  tty39  tty51  tty7   usbmon0  vcsa4
fb0              lightnvm   ppp                 sda5    sg9     tty14     tty27  tty4   tty52  tty8   usbmon1  vcsa5

Josh
Site Admin
Posts: 6569
Joined: 03 Nov 2007, 00:30

Re: HSUPA Qualcomm CDMA Tech MSM USB-modem don't change the mode

Post by Josh » 27 Jul 2018, 19:57

You can see the change in the modem's configuration much better if you use the following commands.

Before the mode switch:

Code: Select all

# lsusb -v -d 05c6:f000
After the mode switch:

Code: Select all

# lsusb -v -d 05c6:6000

unoc_u34
Posts: 5
Joined: 27 Jul 2018, 09:35

Re: HSUPA Qualcomm CDMA Tech MSM USB-modem don't change the mode

Post by unoc_u34 » 28 Jul 2018, 07:49

Josh wrote:You can see the change in the modem's configuration much better if you use the following commands.

Before the mode switch:

Code: Select all

# lsusb -v -d 05c6:f000
After the mode switch:

Code: Select all

# lsusb -v -d 05c6:6000
Modem I have Chinese! So, I don't know what to expect)) If the modem will be deviations that will appeal to you! You helped me a lot Josh. Thank you very much for that.

Post Reply