Batteries included
Post Reply
timolen
Posts: 4
Joined: 25 Mar 2019, 14:44

ALCATEL L800 building network

Post by timolen » 25 Mar 2019, 14:48

I have some issues with the alcatel modem.

With ppp3 i'm unable to use the modem. The app gets stuck at

Code: Select all

Device manufacturer string: rockchip
Total RAM: 4080 MB. Available RAM: 3217 MB

New device on /dev/bus/usb/003/005
 Class of interface 0 is 0xFF
Looking at USB device 1bbb:0203 with class 255
 Device top dir: /sys/bus/usb/devices/3-1, active cfg: 1
Active configuration ID: 1
Device layout (config 1) - cl:00  sc:00  pr:00
 if:0 as:0 -  cl:ff  sc:ff  pr:ff -  bi:81  bo:01
 if:1 as:0 -  cl:ff  sc:00  pr:00 -  ir:83  bi:82  bo:02
 if:2 as:0 -  cl:ff  sc:ff  pr:ff -  ir:85  bi:84  bo:03
 The table says these values define a QMI port
 if:3 as:0 -  cl:08  sc:06  pr:50 -  bo:04  bi:86

Found 2 serial ports (0, 1)
Opening port type QMI (interface 2)
No MAC descriptor found, use made-up MAC
And with PPP2 it gets stuck at building network:

Code: Select all

Start chat sequence for dialling ...
>
ATE0
<
OK
>
AT+CFUN?
<
+CFUN: 1

OK
>
AT+CGDCONT=1,"IP","net"
<
OK
>
ATD*99***1#
<
CONNECT 100000000
====
Dialling complete


Now start PPP negotiation ...
>
ff03c021010000140206000000000506f7adb02907020802a565
<
ff03c021010000190206000000000305c223050506681ac880070208029700ff03c021020000140206000000000506f7adb029070208024e0c
>
ff03c021030000080304c023f7d7
<
ff03c021010100180206000000000304c0230506681ac880070208028535
>
ff03c021020100180206000000000304c0230506681ac8800702080249d8
>
c0230101000600003b3f
<
ff03c0210b020008681ac880de58
<
c0230201000500fd30
>
802101000016030600000000810600000000830600000000627c
<
80210100000467c380210300001603060a899a2881066da6ca3583066da6ca36e907
>
802102000004aae6
<
802101010004bb99
>
80210201000476bc
<
802101020004df76
>
8021020200041253
<
802101030004032c
>
802102030004ce09
<
80210104000406a0
>
802102040004cb85
<
802101050004dafa
>
80210205000417df
<
802101060004be15
>
8021020600047330
<
802101070004624f
>
802102070004af6a
<
802101080004a505
>
8021020800046820
<
802101090004795f
>
802102090004b47a
<
8021010a00041db0
>
8021020a0004d095
<
8021010b0004c1ea
>
8021020b00040ccf
<
8021010c0004c466
>
8021020c00040943
<
8021010d0004183c
>
8021020d0004d519
Any ideas what i can try to make it work?

Thanks!

Josh
Site Admin
Posts: 6569
Joined: 03 Nov 2007, 00:30

Re: ALCATEL L800 building network

Post by Josh » 25 Mar 2019, 20:52

Not sure what's wrong ...

Do you get no PPP Log at all with PPP Widget 3 after trying to connect?

timolen
Posts: 4
Joined: 25 Mar 2019, 14:44

Re: ALCATEL L800 building network

Post by timolen » 25 Mar 2019, 20:55

No PPP log at all. But i do get the "Developer warning for package "de.draisberghof.pppwidget3" Failed to post notification on channel "null" See log for more details" prompt error and gets stuck at installing device, if i remember correctly.

Josh
Site Admin
Posts: 6569
Joined: 03 Nov 2007, 00:30

Re: ALCATEL L800 building network

Post by Josh » 27 Mar 2019, 00:38

I have ordered such a modem on eBay. It's better to have it here on my desk.
It might take a while as it comes from the assumingly beautiful city of Shenzen ...

However, there is a chance that your phone/tablet is the real culprit. I have never seen a warning like you describe it. I have 14 different tablet and one Samsung phone to test with.

Are you running a largely unaltered Android or a customized version?

timolen
Posts: 4
Joined: 25 Mar 2019, 14:44

Re: ALCATEL L800 building network

Post by timolen » 27 Mar 2019, 11:12

It is very lightly customized, based on android nougat. It's strange how on ppp2 it goes further than ppp3 but still gets stuck on building network even if i let it for 20minutes. The log just fills with the below and so on

Code: Select all

ff03c0210b020008681ac880de58
<
c0230201000500fd30
>
802101000016030600000000810600000000830600000000627c
<
80210100000467c380210300001603060a899a2881066da6ca3583066da6ca36e907
>
802102000004aae6
<
802101010004bb99
>
80210201000476bc
<
802101020004df76
>
8021020200041253

Josh
Site Admin
Posts: 6569
Joined: 03 Nov 2007, 00:30

Re: ALCATEL L800 building network

Post by Josh » 28 Mar 2019, 09:47

I will see if I can add an option to PPP Widget 3 where you can force it to use a serial port with PPP instead of the auto-detected protocol.

I will not put any further work into PPP Widget 2 though. It's obsolete.

timolen
Posts: 4
Joined: 25 Mar 2019, 14:44

Re: ALCATEL L800 building network

Post by timolen » 04 Apr 2019, 10:46

Regarding the "null" notification, i have tried another usb modem, and even though i receive that error, the modem works as it should.
So it seems that in this case the alcatel modem is having an issue with your app. This is just a fyi, in further development.

Good job on your work! Congrats!

Josh
Site Admin
Posts: 6569
Joined: 03 Nov 2007, 00:30

Re: ALCATEL L800 building network

Post by Josh » 15 Apr 2019, 21:36

I have received the L800 I ordered.

Stand by while research starts ...

Josh
Site Admin
Posts: 6569
Joined: 03 Nov 2007, 00:30

Re: ALCATEL L800 building network

Post by Josh » 17 Apr 2019, 08:17

First attempts (short, due to time restraints):

My main development tablet has trouble handling and recognizing the modem at all. It sometimes even reboots spontaneously.

Seems to be a real bugger.

Post Reply