Activation Codes and Methods, Hardware Details, Sniffing
Post Reply
brcisna
Posts: 1
Joined: 10 Aug 2021, 18:15

4G LTE dongle power cycles

Post by brcisna » 10 Aug 2021, 19:27

Hello ALL,

First time posting here .

Debian Bullseye

4G LTE USB modem wifi dongle -- Bus 003 Device 041: ID 05c6:6000 Qualcomm, Inc. Siemens SG75
This modem boots up fine without a sim card in it,,,and get green light . Doing an mmcli -L and mmcli -m # information is shown as expected less sim card not installed.
Once place sim card in the modem,,in about 2 minutes it continually power cycles. After lots of dmesg look ,,see ,, if i disable ModemManager.service the modem stays lit continually and does not power cycle .
with ModemManager.service enabled see continually in dmesg usb modem disconnected then reconnected.
Have 6 brand new sim cards to try,,all with same results.

A sidenote,,on the same machine dual boot nothing changed,,, into Windows 10 the modem does not power cycle,,sim card detected etc.
Tried on both USB 2.0 and 3.0 ports on two different machines.

Dont think there is any way of disabling the sd card drive on these. Would like to do this just to cut down on required power.

Is it the simple fact the modem isn't receiving enough power? Do not have a powered USB hub to try. Always think a powered hub is a band aid for whatever you are using it for.

EDIT: After a long period of time booted up finally stays green . Have read this in other forums it takes aloong time for these to become avaliable?
But doing mmcli -m ##
General | dbus path: /org/freedesktop/ModemManager1/Modem/1
| device id: 63e104ff6fa5d96b92bdd79f24a04ade4ae7aeba
-----------------------------
Hardware | manufacturer: QUALCOMM INCORPORATED
| model: 0
| firmware revision: MDM9K-QXWL-U-5B_V30.2 1 [Jan 19 2012 21:00:00]
| supported: gsm-umts, lte
| current: gsm-umts, lte
| equipment id: ######################
-----------------------------
System | device: /sys/devices/pci0000:00/0000:00:1d.7/usb3/3-2
| drivers: option1
| plugin: generic
| primary port: ttyUSB0
| ports: ttyUSB0 (at), ttyUSB1 (at), ttyUSB3 (qcdm)
-----------------------------
Status | state: failed
| failed reason: unknown
| signal quality: 0% (cached)
-----------------------------
Modes | supported: allowed: 2g, 3g, 4g; preferred: none
| current: allowed: any; preferred: none

SIM card is never detected.

Sidenote: This modem after being powered up for a couple hours becomes very very warm- almost hot!


Thank You
Attachments
modemmanager.png
modemmanager.png (40.26 KiB) Viewed 958 times

LOM
Posts: 1397
Joined: 11 Jul 2012, 15:14
Location: Koh Samui, TH

Re: 4G LTE dongle power cycles

Post by LOM » 11 Aug 2021, 05:11

brcisna wrote: 10 Aug 2021, 19:27 if i disable ModemManager.service the modem stays lit continually and does not power cycle .
with ModemManager.service enabled see continually in dmesg usb modem disconnected then reconnected.
Not a usb_modeswitch problem, try modemmanager mailing list.
I also very much doubt that your dongle is 4G LTE conformant.

Post Reply