Activation Codes and Methods, Hardware Details, Sniffing
Post Reply
bond2bill
Posts: 1
Joined: Thu Apr 23, 2020 9:38 am

"KuWfi 4g LTE USB dongle" won't switch modes

Post by bond2bill » Thu Apr 23, 2020 10:25 am

Hi all,

I have a "Biuzi 4G Router W02-LW43 150Mbps Wireless unlocked USB dongle" (See more: https://www.amazon.com/Biuzi-W02-LW43-W ... 086HJR982/)

Info about USB Dongle:
- Model number: W02-LW43
- CPU type: Qualcomm MDM9307
- vID/pID: 05c6:f00e Qualcomm, Inc.
When plugin, it will running mode "RNDIS device" (rdis_host).

lsusb : Bus 001 Device 005: ID 05c6:f00e Qualcomm, Inc.

lsusb -t
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/6p, 480M
|__ Port 1: Dev 5, If 0, Class=Wireless, Driver=rndis_host, 480M
|__ Port 1: Dev 5, If 1, Class=CDC Data, Driver=rndis_host, 480M
dmesg | grep usb

Code: Select all

[ 6583.477867] usb 1-1: new high-speed USB device number 4 using ehci-pci
[ 6583.525962] usb 1-1: New USB device found, idVendor=05c6, idProduct=f000, bcdDevice= 3.18
[ 6583.525964] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 6583.525965] usb 1-1: Manufacturer: Qualcomm
[ 6583.525966] usb 1-1: SerialNumber: 0123456789ABCDEF
[ 6583.531379] usb-storage 1-1:1.0: USB Mass Storage device detected
[ 6583.531812] scsi host33: usb-storage 1-1:1.0
[ 6584.594059] usb 1-1: USB disconnect, device number 4
[ 6585.437868] usb 1-1: new high-speed USB device number 5 using ehci-pci
[ 6585.488300] usb 1-1: New USB device found, idVendor=05c6, idProduct=f00e, bcdDevice= 3.18
[ 6585.488301] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 6585.488302] usb 1-1: Manufacturer: Qualcomm
[ 6585.488303] usb 1-1: SerialNumber: 0123456789ABCDEF
[ 6585.509230] usbcore: registered new interface driver cdc_ether
[ 6585.533766] rndis_host 1-1:1.0 eth0: register 'rndis_host' at usb-0000:02:03.0-1, RNDIS device, fc:de:56:ff:01:06
[ 6585.533909] usbcore: registered new interface driver rndis_host
and I want to switch mode it to Modem mode to dial (wvdial on ubuntu).

When I use usb_modeswitch -v 05c6 -p f00e -W -K

Code: Select all

Take all parameters from the command line

 * usb_modeswitch: handle USB devices with multiple modes
 * Version 2.5.2 (C) Josua Dietze 2017
 * Based on libusb1/libusbx

 ! PLEASE REPORT NEW CONFIGURATIONS !

DefaultVendor=  0x05c6
DefaultProduct= 0xf00e

StandardEject=1

Look for default devices ...
  found USB ID 05c6:f00e
   vendor ID matched
   product ID matched
  found USB ID 1d6b:0002
  found USB ID 0e0f:0002
  found USB ID 0e0f:0003
  found USB ID 1d6b:0001
 Found devices in default mode (1)
Access device 005 on bus 001
Get the current device configuration ...
Current configuration number is 1
Use interface number 0
 with class 224

Error: can't use storage command in MessageContent with interface 0; interface class is 224, expected 8. Abort
lsusb -v -d 05c6:f00e

Code: Select all

Bus 001 Device 005: ID 05c6:f00e Qualcomm, Inc. 
Couldn't open device, some information will be missing
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  idVendor           0x05c6 Qualcomm, Inc.
  idProduct          0xf00e 
  bcdDevice            3.18
  iManufacturer           1 
  iProduct                2 
  iSerial                 3 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           75
    bNumInterfaces          2
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0x80
      (Bus Powered)
    MaxPower              500mA
    Interface Association:
      bLength                 8
      bDescriptorType        11
      bFirstInterface         0
      bInterfaceCount         2
      bFunctionClass        224 Wireless
      bFunctionSubClass       1 Radio Frequency
      bFunctionProtocol       3 RNDIS
      iFunction               8 
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass       224 Wireless
      bInterfaceSubClass      1 Radio Frequency
      bInterfaceProtocol      3 RNDIS
      iInterface              6 
      ** UNRECOGNIZED:  05 24 00 10 01
      ** UNRECOGNIZED:  05 24 01 00 01
      ** UNRECOGNIZED:  04 24 02 00
      ** UNRECOGNIZED:  05 24 06 00 01
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x82  EP 2 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0008  1x 8 bytes
        bInterval               9
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        1
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass        10 CDC Data
      bInterfaceSubClass      0 Unused
      bInterfaceProtocol      0 
      iInterface              7 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
I've tried changing -K for -H, -J, -X etc but nothing has any effect.

After i using nmap to scan port open of USB, result:

Code: Select all

nmap -A -p 1-65535 192.168.1.1
Starting Nmap 7.80 ( https://nmap.org ) at 2020-04-23 14:09 +07
Nmap scan report for _gateway (192.168.1.1)
Host is up (0.024s latency).
Not shown: 65531 closed ports
PORT      STATE SERVICE  VERSION
53/tcp    open  domain   dnsmasq 2.68
| dns-nsid: 
|_  bind.version: dnsmasq-2.68
80/tcp    open  http     Boa HTTPd 0.94.14rc21
|_http-server-header: Boa/0.94.14rc21
5555/tcp  open  freeciv?
61726/tcp open  http     Smartfren EVDO modem httpd
|_http-server-header: Venky
|_http-title: Site doesn't have a title (text/html).
|_http-trane-info: Problem with XML parsing of /evox/about
Please help me to switch mode to Modem to dial.

Thank to all.

LOM
Posts: 1304
Joined: Wed Jul 11, 2012 3:14 pm
Location: Koh Samui, TH

Re: "KuWfi 4g LTE USB dongle" won't switch modes

Post by LOM » Fri Apr 24, 2020 2:30 am

This dongle is a MiFi router and it has no ppp dial-up modem function.

Post Reply